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Copyright © 2001 Nortel Networks

All rights reserved. March 2001.

The information in this document is subject to change without notice. The statements, configurations, technical data, and 
recommendations in this document are believed to be accurate and reliable, but are presented without express or implied 
warranty. Users must take full responsibility for their applications of any products specified in this document. The 
information in this document is proprietary to Nortel Networks NA Inc. 

The software described in this document is furnished under a license agreement and may be used only in accordance 
with the terms of that license. The software license agreement is included in this document.

Trademarks

NORTEL NETWORKS is a trademark of Nortel Networks.

Optivity and Passport are registered trademarks and BayStack is a trademark of Nortel Networks.

Microsoft, Windows, and Windows NT are registered trademarks of Microsoft Corporation.

All other trademarks and registered trademarks are the property of their respective owners.

Restricted rights legend

Use, duplication, or disclosure by the United States Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

Notwithstanding any other license agreement that may pertain to, or accompany the delivery of, this computer software, 
the rights of the United States Government regarding its use, reproduction, and disclosure are as set forth in the 
Commercial Computer Software-Restricted Rights clause at FAR 52.227-19.

Statement of conditions

In the interest of improving internal design, operational function, and/or reliability, Nortel Networks NA Inc. reserves 
the right to make changes to the products described in this document without notice.

Nortel Networks NA Inc. does not assume any liability that may occur due to the use or application of the product(s) or 
circuit layout(s) described herein.

Portions of the code in this software product may be Copyright © 1988, Regents of the University of California. All 
rights reserved. Redistribution and use in source and binary forms of such portions are permitted, provided that the 
above copyright notice and this paragraph are duplicated in all such forms and that any documentation, advertising 
materials, and other materials related to such distribution and use acknowledge that such portions of the software were 
developed by the University of California, Berkeley. The name of the University may not be used to endorse or promote 
products derived from such portions of the software without specific prior written permission.

SUCH PORTIONS OF THE SOFTWARE ARE PROVIDED “AS IS” AND WITHOUT ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

In addition, the program and information contained herein are licensed only pursuant to a license agreement that contains 
restrictions on use and disclosure (that may incorporate by reference certain limitations and notices imposed by third 
parties).
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Nortel Networks NA Inc. software license agreement

NOTICE: Please carefully read this license agreement before copying or using the accompanying software or installing 
the hardware unit with pre-enabled software (each of which is referred to as “Software” in this Agreement). BY 
COPYING OR USING THE SOFTWARE, YOU ACCEPT ALL OF THE TERMS AND CONDITIONS OF THIS 
LICENSE AGREEMENT. THE TERMS EXPRESSED IN THIS AGREEMENT ARE THE ONLY TERMS UNDER 
WHICH NORTEL NETWORKS WILL PERMIT YOU TO USE THE SOFTWARE. If you do not accept these terms 
and conditions, return the product, unused and in the original shipping container, within 30 days of purchase to obtain a 
credit for the full purchase price.

1. License grant. Nortel Networks NA Inc. (“Nortel Networks”) grants the end user of the Software (“Licensee”) a 
personal, nonexclusive, nontransferable license: a) to use the Software either on a single computer or, if applicable, on a 
single authorized device identified by host ID, for which it was originally acquired; b) to copy the Software solely for 
backup purposes in support of authorized use of the Software; and c) to use and copy the associated user manual solely 
in support of authorized use of the Software by Licensee. This license applies to the Software only and does not extend 
to Nortel Networks Agent software or other Nortel Networks software products. Nortel Networks Agent software or 
other Nortel Networks software products are licensed for use under the terms of the applicable Nortel Networks NA Inc. 
Software License Agreement that accompanies such software and upon payment by the end user of the applicable 
license fees for such software. 

2. Restrictions on use; reservation of rights. The Software and user manuals are protected under copyright laws. 
Nortel Networks and/or its licensors retain all title and ownership in both the Software and user manuals, including any 
revisions made by Nortel Networks or its licensors. The copyright notice must be reproduced and included with any 
copy of any portion of the Software or user manuals. Licensee may not modify, translate, decompile, disassemble, use 
for any competitive analysis, reverse engineer, distribute, or create derivative works from the Software or user manuals 
or any copy, in whole or in part. Except as expressly provided in this Agreement, Licensee may not copy or transfer the 
Software or user manuals, in whole or in part. The Software and user manuals embody Nortel Networks’ and its 
licensors’ confidential and proprietary intellectual property. Licensee shall not sublicense, assign, or otherwise disclose 
to any third party the Software, or any information about the operation, design, performance, or implementation of the 
Software and user manuals that is confidential to Nortel Networks and its licensors; however, Licensee may grant 
permission to its consultants, subcontractors, and agents to use the Software at Licensee’s facility, provided they have 
agreed to use the Software only in accordance with the terms of this license.

3. Limited warranty. Nortel Networks warrants each item of Software, as delivered by Nortel Networks and properly 
installed and operated on Nortel Networks hardware or other equipment it is originally licensed for, to function 
substantially as described in its accompanying user manual during its warranty period, which begins on the date 
Software is first shipped to Licensee. If any item of Software fails to so function during its warranty period, as the sole 
remedy Nortel Networks will at its discretion provide a suitable fix, patch, or workaround for the problem that may be 
included in a future Software release. Nortel Networks further warrants to Licensee that the media on which the 
Software is provided will be free from defects in materials and workmanship under normal use for a period of 90 days 
from the date Software is first shipped to Licensee. Nortel Networks will replace defective media at no charge if it is 
returned to Nortel Networks during the warranty period along with proof of the date of shipment. This warranty does not 
apply if the media has been damaged as a result of accident, misuse, or abuse. The Licensee assumes all responsibility 
for selection of the Software to achieve Licensee’s intended results and for the installation, use, and results obtained 
from the Software. Nortel Networks does not warrant a) that the functions contained in the software will meet the 
Licensee’s requirements, b) that the Software will operate in the hardware or software combinations that the Licensee 
may select, c) that the operation of the Software will be uninterrupted or error free, or d) that all defects in the operation 
of the Software will be corrected. Nortel Networks is not obligated to remedy any Software defect that cannot be 
reproduced with the latest Software release. These warranties do not apply to the Software if it has been (i) altered, 
except by Nortel Networks or in accordance with its instructions; (ii) used in conjunction with another vendor’s product, 
resulting in the defect; or (iii) damaged by improper environment, abuse, misuse, accident, or negligence. THE 
FOREGOING WARRANTIES AND LIMITATIONS ARE EXCLUSIVE REMEDIES AND ARE IN LIEU OF ALL 
OTHER WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Licensee is responsible for the security of its 
Using Optivity Switch Manager Release 1.1.0.0
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own data and information and for maintaining adequate procedures apart from the Software to reconstruct lost or altered 
files, data, or programs.

4. Limitation of liability. IN NO EVENT WILL NORTEL NETWORKS OR ITS LICENSORS BE LIABLE FOR 
ANY COST OF SUBSTITUTE PROCUREMENT; SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES; OR ANY DAMAGES RESULTING FROM INACCURATE OR LOST DATA OR LOSS OF USE OR 
PROFITS ARISING OUT OF OR IN CONNECTION WITH THE PERFORMANCE OF THE SOFTWARE, EVEN IF 
NORTEL NETWORKS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT 
SHALL THE LIABILITY OF NORTEL NETWORKS RELATING TO THE SOFTWARE OR THIS AGREEMENT 
EXCEED THE PRICE PAID TO NORTEL NETWORKS FOR THE SOFTWARE LICENSE.

5. Government licensees. This provision applies to all Software and documentation acquired directly or indirectly by or 
on behalf of the United States Government. The Software and documentation are commercial products, licensed on the 
open market at market prices, and were developed entirely at private expense and without the use of any U.S. 
Government funds. The license to the U.S. Government is granted only with restricted rights, and use, duplication, or 
disclosure by the U.S. Government is subject to the restrictions set forth in subparagraph (c)(1) of the Commercial 
Computer Software––Restricted Rights clause of FAR 52.227-19 and the limitations set out in this license for civilian 
agencies, and subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause of DFARS 
252.227-7013, for agencies of the Department of Defense or their successors, whichever is applicable.

6. Use of software in the European Community. This provision applies to all Software acquired for use within the 
European Community. If Licensee uses the Software within a country in the European Community, the Software 
Directive enacted by the Council of European Communities Directive dated 14 May, 1991, will apply to the examination 
of the Software to facilitate interoperability. Licensee agrees to notify Nortel Networks of any such intended 
examination of the Software and may procure support and assistance from Nortel Networks.

7. Term and termination. This license is effective until terminated; however, all of the restrictions with respect to 
Nortel Networks’ copyright in the Software and user manuals will cease being effective at the date of expiration of the 
Nortel Networks copyright; those restrictions relating to use and disclosure of Nortel Networks’ confidential information 
shall continue in effect. Licensee may terminate this license at any time. The license will automatically terminate if 
Licensee fails to comply with any of the terms and conditions of the license. Upon termination for any reason, Licensee 
will immediately destroy or return to Nortel Networks the Software, user manuals, and all copies. Nortel Networks is not 
liable to Licensee for damages in any form solely by reason of the termination of this license.

8. Export and re-export. Licensee agrees not to export, directly or indirectly, the Software or related technical data or 
information without first obtaining any required export licenses or other governmental approvals. Without limiting the 
foregoing, Licensee, on behalf of itself and its subsidiaries and affiliates, agrees that it will not, without first obtaining all 
export licenses and approvals required by the U.S. Government: (i) export, re-export, transfer, or divert any such 
Software or technical data, or any direct product thereof, to any country to which such exports or re-exports are restricted 
or embargoed under United States export control laws and regulations, or to any national or resident of such restricted or 
embargoed countries; or (ii) provide the Software or related technical data or information to any military end user or for 
any military end use, including the design, development, or production of any chemical, nuclear, or biological weapons.

9. General. If any provision of this Agreement is held to be invalid or unenforceable by a court of competent 
jurisdiction, the remainder of the provisions of this Agreement shall remain in full force and effect. This Agreement will 
be governed by the laws of the state of California.

Should you have any questions concerning this Agreement, contact Nortel Networks, 4401 Great America Parkway, P.O. 
Box 58185, Santa Clara, California 95054-8185.

LICENSEE ACKNOWLEDGES THAT LICENSEE HAS READ THIS AGREEMENT, UNDERSTANDS IT, AND 
AGREES TO BE BOUND BY ITS TERMS AND CONDITIONS. LICENSEE FURTHER AGREES THAT THIS 
AGREEMENT IS THE ENTIRE AND EXCLUSIVE AGREEMENT BETWEEN NORTEL NETWORKS AND 
LICENSEE, WHICH SUPERSEDES ALL PRIOR ORAL AND WRITTEN AGREEMENTS AND 
COMMUNICATIONS BETWEEN THE PARTIES PERTAINING TO THE SUBJECT MATTER OF THIS 
AGREEMENT. NO DIFFERENT OR ADDITIONAL TERMS WILL BE ENFORCEABLE AGAINST NORTEL 
NETWORKS UNLESS NORTEL NETWORKS GIVES ITS EXPRESS WRITTEN CONSENT, INCLUDING AN 
EXPRESS WAIVER OF THE TERMS OF THIS AGREEMENT.
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Preface

Optivity Switch Manager is a Java-based graphical network management 
application used to configure and manage select Passport and BayStack switches 
and Business Policy Switch 2000 switches operating within the same local area 
network.

This guide provides information about installing the Optivity Switch Manager 
software and using the features and capabilities of Optivity Switch Manager’s 
graphical user interface (GUI).

Before you begin

This guide is intended for network administrators with the following background:

• Working knowledge of networks and Ethernet bridging

• Ability to configure and troubleshoot VLANs, STGs, MLTs, and Multicast 
groups

• Familiarity with networking concepts and terminology

• Working knowledge of GUIs
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Text conventions

This guide uses the following text conventions: 

Related publications

For more information about the protocols used in Optivity Switch Manager or 
information about using Device Manager, refer to the publications in this list. 

bold Courier text Indicates command names and options and text that 
you need to enter.
Example: Use the dinfo command. 
Example: Enter show ip {alerts|routes}.

italic text Indicates new terms, book titles, and variables in 
command syntax descriptions. Where a variable is two 
or more words, the words are connected by an 
underscore.
Example: If the command syntax is
show at <valid_route>, valid_route is one
variable and you substitute one value for it.

plain Courier text Indicates command syntax and system output, for 
example, prompts and system messages.
Example: Set Trap Monitor Filters

separator ( > ) Shows menu paths. 
Example: Protocols > IP identifies the IP option on the 
Protocols menu. 

Note: The Passport product line was formerly named Accelar. The 
product name on some previously published documents has not yet been 
changed.
208963-B



Preface 19

  
• Networking Concepts for the Accelar 1000 Series Routing Switch Software 
Release 2.0 (part number 205588-A)

Provides general information and description of how the Passport 1000 Series 
switch handles various networking features, such as VLANs, MultiLink 
Trunking, OSPF, RIP, and IPX.

• Installing Optivity Switch Manager for LAN Switch Networks 1.0.0.0 
(part number 210274-A)

Describes the steps necessary to install Optivity Switch Manager on the 
Windows and Solaris platforms.

• Networking Concepts for the Passport 8000 Series Switch 
(part number 207307-C)

Provides general information and description of how the Passport switch 
handles various networking features, such as VLANs, MultiLink Trunking, 
OSPF, RIP, and IPX.

• Reference for the Passport 8000 Series Command Line Interface Basic Switch 
Management Release 3.1 (part number 211255-A)

Describes the command line interface (CLI) structure and the commands used 
to perform basic switch management operations, such as modifying the switch 
boot sequence, working with switch files, and setting up security features.

• Reference for the Passport 8000 Series Command Line Interface Switching 
Operations Release 3.1 (part number 207308-D)

Describes the CLI commands and parameters for switching operations. Most 
configuration tasks that can be performed using Device Manager can also be 
done using the CLI. 

• Reference for the Passport 8000 Series Command Line Interface Routing 
Operations Release 3.1 (part number 208967-C)

Describes the CLI commands and parameters for routing operations.

• Reference for Accelar Management Software Switching Operations 
Release 2.0 (part number 205586-A)

Describes how to use Device Manager to configure and manage layer 2 
(switching) functions with the Accelar 1000 Series routing switch, including 
procedures and illustrations of pertinent screens.
Using Optivity Switch Manager, Release 1.1.0.0
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• Reference for Accelar Management Software Routing Operations Release 2.0 
(part number 205587-A)

Describes how to use Device Manager to configure and manage layer 3 
(routing) functions with the Accelar 1000 Series routing switch, including 
procedures and illustrations of pertinent screens.

• Reference for the Passport 8000 Series Management Software Switching 
Operations Release 3.1 (part number 207414-D)

Describes how to use Device Manager to configure and manage layer 3 
(routing) functions with the Passport routing switch, including procedures and 
illustrations of pertinent screens.

• Reference for the Passport 8000 Series Management Software Routing 
Operations Release 3.1 (part number 207415-C)

Describes how to use Device Manager to configure and manage layer 2 
(switching) functions with the Passport 8000 Series switch, including 
procedures and illustrations of pertinent screens.

• Reference for the BayStack 350/410/450 Management Software Operations 
Version 3.1 (part number 210245-B)

Describes how to use Device Manager to configure and manage layer 2 
(switching) functions with BayStack switches, including procedures and 
illustrations of pertinent screens.

You can print selected technical manuals and release notes free, directly from the 
Internet. Go to the www25.nortelnetworks.com/library/tpubs/ URL. Find the 
product for which you need documentation. Then locate the specific category and 
model or version for your hardware or software product. Use Adobe Acrobat 
Reader to open the manuals and release notes, search for the sections you need, 
and print them on most standard printers. Go to Adobe Systems at the 
www.adobe.com URL to download a free copy of the Adobe Acrobat Reader.

You can purchase selected documentation sets, CDs, and technical publications 
through the Internet at the www1.fatbrain.com/documentation/nortel/ URL.
208963-B
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How to get help

If you purchased a service contract for your Nortel Networks product from a 
distributor or authorized reseller, contact the technical support staff for that 
distributor or reseller for assistance.

If you purchased a Nortel Networks service program, contact one of the following 
Nortel Networks Technical Solutions Centers:

An Express Routing Code (ERC) is available for many Nortel Networks products 
and services. When you use an ERC, your call is routed to a technical support 
person who specializes in supporting that product or service. To locate an ERC for 
your product or service, go to the www12.nortelnetworks.com/ URL and click 
ERC at the bottom of the page.

Technical Solutions Center Telephone

EMEA (33) (4) 92-966-968

North America (800) 4NORTEL or (800) 466-7835

Asia Pacific (61) (2) 9927-8800

China (800) 810-5000
Using Optivity Switch Manager, Release 1.1.0.0
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Chapter 1
Introducing Optivity Switch Manager

This chapter introduces Nortel Networks Optivity Switch Manager features and 
functions. The chapter includes the following topics:

• What is Optivity Switch Manager? (next)

• Optivity Switch Manager features (page 24)

• Optivity Switch Manager submanagers (page 24)

What is Optivity Switch Manager?

Optivity Switch Manager is a Java-based network management application that 
allows you to discover and view up to 100 network devices and their physical 
links on a topology map. Once your network is discovered, you can monitor, 
manage, and configure protocols and settings in devices in the network using the 
following submanagers within Optivity Switch Manager:

• VLAN Manager

• MultiLink Trunking Manager

• Multicast Manager

• Log Manager

In addition to these submanagers, Optivity Switch Manager has an associated 
standalone application, Device Manager, that provides the ability to completely 
configure and manage a single device in the network.

Optivity Switch Manager allows you to manage small to medium-size networks. 
Since Optivity Switch Manager is a Java-based tool, it is platform-independent. 
Optivity Switch Manager is also a real-time SNMP tool, allowing you to save the 
topology map, error log, preferences, and communities in the application. 
Using Optivity Switch Manager, Release 1.1.0.0
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To use Optivity Switch Manager, you must have the Java Runtime Environment 
(JRE) installed on your system. Optivity Switch Manager requires JRE 1.3.

Optivity Switch Manager features

Optivity Switch Manager is a configuration tool for troubleshooting and limited 
network monitoring. It has the following features:

• A consistent look across the Solaris and Windows platforms.

• Spring algorithm that balances distances between devices and minimizes 
crossing lines when creating the topology map.

• A consistent graphical user interface (GUI) across Optivity Switch Manager 
and submanagers and a single point of access to the submanagers.

• Dynamic system updates across submanagers. You can simultaneously query 
your device in a submanager application as you view the topology map 
through Optivity Switch Manager.

• Access control and security using community strings.

• Network discovery that you can specify to be as large or small as you want.

• Ability to save the layout of a discovered network for future use.

Optivity Switch Manager submanagers

Optivity Switch Manager incorporates submanagers that provide detailed device 
information and management capabilities. The submanagers are designed to 
provide specialized information in an easy-to-use graphical user interface that is 
consistent in layout across the submanagers. A submanager can query Optivity 
Switch Manager and instruct the primary application to update the topology view 
with information relevant to the submanager view. For example, VLAN Manager 
can instruct Optivity Switch Manager to color all the devices in the view that 
include members of a particular VLAN.

Note: For a description of operating systems, devices, and software 
releases supported by Optivity Switch Manager, see Installing Optivity 
Switch Manager, Release 1.1.0.0.
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The submanagers open in a separate window from Optivity Switch Manager. You 
must have the Optivity Switch Manager window open to access all the 
submanagers except Device Manager. The submanagers are:

• VLAN Manager

• MultiLink Trunking Manager

• Multicast Manager

• Log Manager

• Device Manager

VLAN Manager

VLAN Manager allows you to:

• Create, delete, or modify VLANs across one or multiple devices

• View VLAN information, membership, and port configuration information in 
tabular format

• View Spanning Tree Protocol information such as members of spanning tree 
groups (STGs) and Spanning Tree Protocol configuration

• View VLAN nodes across the network

For more information about VLAN Manager, refer to Chapter 4, “Using VLAN 
Manager,” on page 55.

MultiLink Trunking Manager

MultiLink Trunking Manager allows you to:

• Create, delete, or modify MultiLink Trunks (MLTs) across one or two devices

• View MLT configuration information such as port and VLAN membership

For more information about MultiLink Trunking Manager, refer to Chapter 5, 
“Using MultiLink Trunking Manager,” on page 99. 
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Multicast Manager

Multicast Manager allows you to:

• View multicast configuration and protocols found in the network

• Display multicast forwarding paths from a selected source or group

For more information about Multicast Manager, refer to Chapter 6, “Using 
Multicast Manager,” on page 121.

Log Manager

Log manager allows you to download individual log files from network devices 
and view the entire file or selected information. 

For more information about Log Manager, refer to Chapter 7, “Using Log 
Manager,” on page 165.

Device Manager

Device Manager is a standalone application that you can launch either from 
Optivity Switch Manager or separately. This application allows you to:

• Download image and configuration files

• Completely manage and configure layer 2 and, if applicable, layer 3 protocols 
and features for a single network device

• Monitor traffic flow through the device

• View a device image indicating which ports are active and, for Passport 
switches, which modules are installed

For more information about Device Manager, refer to the documents listed in 
“Related publications” on page 18.
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Chapter 2
Using Optivity Switch Manager

This chapter describes the basic procedures for using Optivity Switch Manager. 
For information about how to install Optivity Switch Manager, refer to Installing 
Optivity Switch Manager,  Release 1.1.0.0. 

This chapter includes the following topics:

• Starting Optivity Switch Manager, next

• Using the Optivity Switch Manager window (page 29)

• Working with the network topology map (page 41)

• Getting help (page 46)
Using Optivity Switch Manager, Release 1.1.0.0
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Starting Optivity Switch Manager

After you install Optivity Switch Manager, you can start the application.

To start Optivity Switch Manager:

• From the Windows 95, Windows 98, Windows 2000, or Windows NT 
Start menu, choose Programs > Nortel Optivity Switch Management 
Software > Optivity Switch Manager.

• In a Windows environment, double-click the Optivity Switch Manager 
shortcut icon on your desktop, if it is present.

• In a Solaris terminal window, enter ./OSM in the location where Optivity 
Switch Manager has been installed.

Optivity Switch Manager starts.

You do not need a password to open the application. However, to discover and 
display a network topology, you need to enter an IP address to a device that will 
act as a “seed,” and you must have permission to access that “seed” device. Refer 
to “Discovering devices on a network” on page 48 for more information.

Do one of the following:
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Using the Optivity Switch Manager window

The Optivity Switch Manager window:

• Displays a logical map of a network showing physical connectivity between 
devices.

• Provides tools to access other Optivity Switch Manager features.

• Allows you to launch Optivity Switch Manager submanagers.

After the initial discovery, other Optivity Switch Manager submanager 
applications allow you to monitor or configure discovered devices.

Figure 1 shows the Optivity Switch Manager window.

Figure 1   Optivity Switch Manager window

Note: The Optivity Switch Manager window remains open and can 
display highlighted devices after the Optivity Switch Manager 
submanager windows open. If you close the Optivity Switch Manager 
window while Optivity Switch Manager submanager windows are open, 
the submanagers also close.

Scale slider

Contents

Scroll bars

Toolbar
Menu bar

Title bar

Status bar

pane
Using Optivity Switch Manager, Release 1.1.0.0



30 Chapter 2 Using Optivity Switch Manager

  
Table 1 describes the parts of the Optivity Switch Manager window.

When you successfully query a device on the network, the Optivity Switch 
Manager contents pane presents a logical map of the network displaying a variety 
of information about the network connections. The specific information available 
on the network topology map depends on the size of the network discovered. For 
example, in a very large network topology, the device IP addresses and port 
numbers are not displayed unless you magnify the network topology map using 
the scale slider.

Optivity Switch Manager menu bar

The menu bar provides menus and commands for operating Optivity Switch 
Manager and for accessing Device Manager, VLAN Manager, MultiLink 
Trunking Manager, Multicast Manager, and Log Manager. Table 2 lists the 
Optivity Switch Manager menus and commands.

Table 1   Parts of the Optivity Switch Manager window

Part Description

Title bar Displays the application name and software version.

Menu bar Provides access to all Optivity Switch Manager commands.

Toolbar Provides quick access to commonly-used Optivity Switch Manager 
commands.

Scale slider Provides four zoom levels to magnify the network topology map.

Contents pane Displays the network topology map.

Scroll bars Provide access to an entire map, table, or other text that spans two 
pages in the contents pane.

Status bar Displays status information and the map legend.
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Table 2   Optivity Switch Manager menus and commands

Menu Command
Shortcut 
keys Description

File Open [Ctrl]+O Opens a topology map.

Save [Ctrl]+S Saves a topology map.

Print [Ctrl]+P Opens the Print dialog box, where you set print parameters.

Exit [Ctrl]+Q Exits Optivity Switch Manager.

Edit Communities Edits SNMP communities accessible by Optivity Switch 
Manager. Refer to “Accessing devices within different 
SNMP communities” on page 53 for more information.

Preferences Edits network preferences and identifies seed addresses 
used by Optivity Switch Manager. Refer to Chapter 3, 
“Configuring Optivity Switch Manager,” on page 48 for more 
information.

Clear Map [Del] Deletes the current network topology displayed in the 
contents pane.

Find Device in 
Map

[Ctrl]+F Opens the Find Device dialog box, where you set 
parameters to find a device in the topology map.

Select All Selects all devices within a supported product family 
(Passport 1000 Series switches, Passport 8000 Series 
switches, or BayStack switches). 

View Link Speeds Displays network link speeds in color on the network 
topology map. The status bar provides a color legend for 
the link speeds (refer to “Optivity Switch Manager status 
bar” on page 38).

Link Duplex Displays half- and full-duplex links in color on the network 
topology map. The status bar provides a color legend for 
the link duplex status (refer to “Optivity Switch Manager 
status bar” on page 38).

Link Types Displays the media type (Ethernet, POS, or ATM) in color 
for the links in the network topology map. The status bar 
provides a color legend for the link types (refer to “Optivity 
Switch Manager status bar” on page 38).

MultiLink Trunks Displays MultiLink Trunks discovered in the network 
topology.

Show Port 
Address

Displays IP addresses of isolated routing ports or brouter 
ports.

Error Log Displays the error log for Optivity Switch Manager. You can 
save the error log to a text file.
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Device Telnet Starts a Telnet session.

Ping Pings a device to test connectivity.

Device Manager Launches Device Manager to monitor and configure the 
selected device.

Properties Displays the properties of the selected device. Refer to 
“Using the Optivity Switch Manager shortcut menu” on 
page 34 for a description of this feature.

Report Opens the Report dialog box, which displays the device IP 
address, name, type, and description.

Dump Topology 
to Log

Dumps the current topology to the log. 

Note: This menu is accessible only if a device is selected on the network map displayed in 
the Optivity Switch Manager Contents pane

Actions Discover Map Discovers a network topology map.

Layout Map Rearranges a topology map for better viewing.

Find Unsaved 
Configurations

Opens the Find Unsaved Configurations dialog box that lists 
the devices with unsaved changes in their configuration 
files. The dialog box contains the device IP address, the 
time/date when the configuration was last changed, and the 
time/date when the device’s configuration was last saved.

Log Manager Opens Log Manager. Refer to Chapter 7, “Using Log 
Manager,” on page 165, for more information about this 
application.

Tools VLAN Manager [F2] Opens VLAN Manager. Refer to Chapter 4, “Using VLAN 
Manager,” on page 55, for more information about this 
application.

MultiLink 
Trunking 
Manager

[F3] Opens MultiLink Trunking Manager. Refer to Chapter 5, 
“Using MultiLink Trunking Manager,” on page 99, for more 
information about this application.

Multicast 
Manager

[F4] Opens Multicast Manager. Refer to Chapter 6, “Using 
Multicast Manager,” on page 121 for more information about 
this application.

Table 2   Optivity Switch Manager menus and commands (continued)

Menu Command
Shortcut 
keys Description
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Finding unsaved configurations

You can find devices that have unsaved configuration files or changed 
configuration files.

To find unsaved configuration files:

The Find Unsaved Configurations dialog box opens (Figure 2).

Figure 2   Find Unsaved Configurations dialog box

Table 3 describes the items in the Find Unsaved Configurations dialog box.

Help Contents [F1] Opens a Web browser application and loads Help files.

Online Support Opens a Web browser that loads the Nortel Networks 
Customer Support Web page.

Legend Displays a key to the icons used in the Optivity Switch 
Manager topology map.

About Optivity 
Switch Manager

Displays Optivity Switch Manager application information.

From the Optivity Switch Manager menu bar, choose Actions > 
Find Unsaved Configurations.

Table 2   Optivity Switch Manager menus and commands (continued)

Menu Command
Shortcut 
keys Description
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Using the Optivity Switch Manager shortcut menu

Use the shortcut menu (Figure 3) to start device-related tasks for a selected 
device. The shortcut menu commands are similar to those found in the Device 
menu and include launching the standalone Device Manager application.

To access the shortcut menu:

The shortcut menu opens (Figure 3).

Figure 3   Shortcut menu

Table 3   Find Unsaved Configurations dialog box items

Item Description

Device The IP address, system name, or host name of the device.

LastChange The date and time when the device’s configuration was last 
changed.

LastSavedToNVRam The date and time when the device’s configuration was last 
saved. If the device’s configuration was never saved, this 
text box reads “none.”

Right-click a device on the topology map to open the shortcut menu.
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Viewing device properties

When you choose Properties from the shortcut menu, you can view properties for 
the selected device. The Device Properties dialog box (Figure 4) includes the 
name, type, and location of the device, if that information was entered in the 
device’s configuration. The bottom of the Device Properties dialog box shows the 
port status of the device.

Figure 4   Device Properties dialog box

Table 4 describes the items in the Device Properties dialog box.

Table 4   Device Properties dialog box items

Item Description

Name The IP address, system name, or host name of the device.

Type The chassis type.

SysName The name of the device.

Description The system-assigned name.

Location The physical location of the device.

Contact The contact information for the system administrator. This 
item reflects the contact information entered as part of the 
system information for this device in Device Manager.

UpTime The time elapsed since the device was last booted.

Ports The device’s port status. The color of the box representing 
each port indicates if the port is up (green), has no link (is 
down) (orange), or is being tested (blue).
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Using the toolbar buttons

The toolbars for Optivity Switch Manager, VLAN Manager, MultiLink Trunking 
Manager, Log Manager, and Multicast Manager are located beneath their 
respective menu bars. The toolbar buttons provide quick access to commonly used 
commands. When a toolbar button is unavailable for a particular configuration or 
submanager, it appears dimmed.

When you point to a button, the name of the button and a description of the 
command function are displayed.

Table 5 describes the toolbar buttons for Optivity Switch Manager and the 
submanagers.

Table 5   Optivity Switch Manager and submanager toolbar buttons

Button Name Description Application

Open Opens a topology map or log file. Optivity Switch Manager, 
Log Manager

Save Saves a topology map or log file. Optivity Switch Manager, 
Log Manager.

Print Prints the topology map.

Note: The application does not paginate the 
map, that is, break the map printing into 
several pages. To print a portion of the map, 
ensure that the portion is visible in the window 
at the desired zoom level.

Optivity Switch Manager, 
VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager, Log 
Manager.

Find Allows you to find a device by IP address, a 
VLAN by name, an MLT by IP address, or a 
multicast group by address. Refer to “Finding 
a device in the topology map” on page 44 for 
more information.

Optivity Switch Manager, 
VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

View Error Log Displays the Optivity Switch Manager error 
log.

Optivity Switch Manager

Discover Network Discovers a seed address in a network. Refer 
to “Discovering devices on a network” on 
page 48 for more information.

Optivity Switch Manager

Stop Discovery Stops the discovery process.
Note: This button is available only while 
discovery is in process.

Optivity Switch Manager
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Layout map Lays out the topology map for better 
readability.

Optivity Switch Manager

Log Manager Starts the Log Manager submanager Optivity Switch Manager

Telnet Opens a Telnet session in a separate window. Optivity Switch Manager

Device Manager Starts the Device Manager submanager. Optivity Switch Manager

Show Device 
Properties

Displays the device properties of a particular 
device on the discovered network.

Optivity Switch Manager

VLAN Manager Starts the VLAN Manager submanager. Optivity Switch Manager

MultiLink Trunking 
Manager

Starts the MultiLink Trunking Manager 
submanager.

Optivity Switch Manager

Multicast Manager Starts the Multicast Manager submanager Optivity Switch Manager

Help Opens online Help. Optivity Switch Manager, 
VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

Reload Reloads the current submanager folder 
information.
Note: Use this function often to ensure that 
the displayed data is the most recent.

VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

Insert Displays the Insert dialog box to add a VLAN, 
STG, or MLT. 

VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

Delete Deletes a selection. VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

Apply Changes Applies changes you have made to the 
configuration.

VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

Table 5   Optivity Switch Manager and submanager toolbar buttons (continued)

Button Name Description Application
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Optivity Switch Manager status bar

The Optivity Switch Manager status bar is at the bottom of the Optivity Switch 
Manager main window (see Figure 1 on page 29). Table 6 describes the fields in 
the status bar.

Undo Changes Undoes changes you have made to the 
configuration if you have not already clicked 
Apply Changes.

VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

 Copy Copies highlighted information. VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager, Log 
Manager

Paste Pastes highlighted information. VLAN Manager, MultiLink 
Trunking Manager, 
Multicast Manager

Table 6   Status bar fields

Field Description

Message Located on the left, the message field displays information about:
• Menu commands and toolbar buttons

• Optivity Switch Manager and submanager operations

Icon Located on the right, the icon field displays a legend for color-coded 
information of Optivity Switch Manager and submanagers. Depending on 
what selections are made from the View menu, this legend shows the 
following information for Optivity Switch Manager:
• Link Speeds—10Mb/s (pink), 100Mb/s (blue), or 1Gb/s (red)

• Link Duplex—Half-duplex (blue) or full duplex (red)
• Link types—Ethernet (blue), POS (red), or ATM (green)
If none of these items is selected from the View menu, this field is blank.

Table 5   Optivity Switch Manager and submanager toolbar buttons (continued)

Button Name Description Application
208963-B



Chapter 2 Using Optivity Switch Manager 39

  
Optivity Switch Manager contents pane icons

After you query a device’s seed address, the topology map opens in the Optivity 
Switch Manager contents pane (Figure 5).

Figure 5   Optivity Switch Manager topology map

The Optivity Switch Manager topology map uses icons to represent the types of 
network devices discovered. Some of the devices are supported by Optivity 
Switch Manager; others are not supported but connect supported devices. 

To access a legend with these icons and their names:

From the Optivity Switch Manager menu bar, choose Help > Legend.
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Table 7 describes the device icons.

Table 7   Device icons

Icon Name Description

Bus Network bus or hub not supported by Optivity 
Switch Manager or its submanagers. You can view 
ports connected to BayStack or Passport switches 
by choosing View > Show Port Address.

Passport 1K Passport 1000 Series switch. This device can be 
configured and monitored by Optivity Switch 
Manager and its submanagers.

Passport 8K Passport 8000 Series switch. This device can be 
configured and monitored by Optivity Switch 
Manager and its submanagers.

BayStack or 
Business Policy 
Switch 2000

BayStack 350, 410, or 450 switch or Business 
Policy Switch 2000. This device can be configured 
and monitored by Optivity Switch Manager and its 
submanagers.

Baystack (old) Baystack 310 switch. This device is partially 
supported by Optivity Switch Manager and its 
submanagers. 

Other switch A switch not supported by Optivity Switch Manager 
or its submanagers.

Other router A router not supported by Optivity Switch Manager 
or its submanagers. 
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Adjusting the contents pane 

You can resize the Optivity Switch Manager window or submanager windows by 
dragging the edges of the active window. You can also use the scroll bars to adjust 
the Optivity Switch Manager contents pane to view a specific portion of the 
discovered network topology. 

Using the scale slider

To adjust the scale of the topology map:

Figure 6   Scale slider

You can display the map up to sixteen times larger.

Working with the network topology map

After a network topology map is loaded into the Optivity Switch Manager 
contents pane, you can save it and reload it.

Move the scale slider (Figure 6) to the right to magnify the map or to the left 
to make it smaller.

Note: Use Edit > Find Device in Map to easily locate the device before 
you resize the specific region of the map.

Note: When you use Optivity Switch Manager in a Solaris environment, 
you can click the number in the scale slider or drag the slider.
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Loading a saved network topology map

You can reload a saved topology map. If you do not have a specific topology map 
saved, the application loads the previously saved topology map. This map is 
stored in the default.topo file.

To open a new topology map, you must use the discovery process described in 
“Discovering devices on a network” on page 48.

To reload a saved topology map: 

1 Do one of the following:

• From the Optivity Switch Manager menu bar, choose File > Open.

• On the keyboard, press [Ctrl]+O.

• On the Optivity Switch Manager toolbar, click Open.

The Open File dialog box opens (Figure 7).

Figure 7   Open File dialog box

2 Select the filename (with a .topo extension) that contains your saved network 
topology.

Note: Optivity Switch Manager Release 1.1.0.0 cannot open topology 
maps saved in earlier releases.
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3 Click Open.

The topology map is displayed in the contents pane.

4 From the Optivity Switch Manager menu bar, choose Actions > Update 
Topology to update your network topology map.

Saving a topology map

When you save a topology map, it is stored with a .topo file extension. If you do 
not save a topology with a specific file name, Optivity Switch Manager attempts 
to save the current map to the default.topo file. 

To save a topology map with another name:

1 Do one of the following:

• From the Optivity Switch Manager menu bar, choose File > Save.

• On the keyboard, press [Ctrl]+S.

• On the Optivity Switch Manager toolbar, click Save.

The Save dialog box opens (Figure 8).

Figure 8   Save dialog box

2 Type the file name with a .topo file extension.

3 Click Save.
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Printing a topology map

To print a topology map: 

• From the Optivity Switch Manager menu bar, choose File > Print.

• On the keyboard, press [Ctrl]+P.

• On the Optivity Switch Manager toolbar, click Print.

Finding a device in the topology map

To locate a device in the network topology map:

1 Do one of the following:

• From the Optivity Switch Manager menu bar, choose Edit > Find Device 
in Map.

• On the keyboard, press [Ctrl]+F.

• On the Optivity Switch Manager toolbar, click Find.

The Find Device dialog box opens (Figure 9).

Figure 9   Find Device dialog box

2 Type the name or the IP address of the device.

3 Click Find.

Do one of the following:

Note: Optivity Switch Manager prints only a single page showing the 
part of the topology map that starts at the left border of the window. To 
print a portion of the map, ensure that the portion is next to the left 
border of the window at the desired zoom level.
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Arranging devices on the topology map

As Optivity Switch Manager discovers devices, they are arranged by default in a 
column (top to bottom/left to right) on the topology map. Figure 10 shows the 
Optivity Switch Manager contents pane after a seed address was located. The 
devices icons are crowded together, and the port numbers and IP addresses 
overlap each other. To improve readability of the map, you can automatically or 
manually adjust the layout.

Figure 10   Optivity Switch Manager display before Layout command

To automatically arrange the topology map:

• From the Optivity Switch Manager menu bar, choose Actions > Layout 
Map. 

• On the Optivity Switch Manager toolbar, click Layout Map.

The nodes are automatically arranged on the map. You may also need to 
manually adjust nodes on the map until you have the desired layout. 

Do one of the following:
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To manually arrange the devices discovered in the network topology:

Getting help

Help in Optivity Switch Manager is arranged by subject. A Web browser, such as 
Netscape Navigator or Microsoft Internet Explorer, opens to display Help files. 
You can use the contents frame or the Help index to locate information.

To access Help: 

• From the Optivity Switch Manager menu bar, choose Help > Contents.

• On the keyboard, press [F1].

• On the Optivity Switch Manager toolbar, click Help.

The Help files open in a Web browser.

Drag selected devices to desired locations on the topology map.

Do one of the following:
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Chapter 3
Configuring Optivity Switch Manager

This chapter describes configuration tools for Optivity Switch Manager, and 
includes the following topics:

• Discovering your network (next)

• Accessing devices within different SNMP communities (page 53)

Discovering your network

Optivity Switch Manager builds its logical map of the network by querying the 
topology table of the seed device, using the Bay Autotopology Protocol (BTP). 
A seed device is a device from which you start learning about the topology of the 
network. After getting the information about the neighbors of the seed device, 
Optivity Switch Manager queries the neighbor devices for their topology tables. 
Optivity Switch Manager then selects the appropriate icon to represent each 
device, computes the links between devices, and represents the device information 
in a network topology map.

Discovery continues until the maximum number of hops is reached. By default, 
Optivity Switch Manager does not query neighbors more than five hops away 
from the seed device. You can set the number of hops, up to a maximum of 20 
hops. Also, you can stop the discovery process at any time by clicking Discovery 
from the Optivity Switch Manager toolbar. While the discovery process is 
occurring, this button changes to show a red X.
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Discovering devices on a network

The topology discovery process begins when you supply Optivity Switch 
Manager with one or more network device seed addresses and the application 
queries the addresses. The Preferences dialog box specifies the seed address and 
defines the scope of the discovery process.

To discover a network:

1 From the Optivity Switch Manager menu bar, choose Edit > Preferences.

The Preferences dialog box opens (Figure 11).

Figure 11   Preferences dialog box

2 In the Seed Address(es) textbox, type the IP address of one or more devices in 
the network.

Separate multiple IP addresses with commas.
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3 In the MaxHops textbox, type the maximum number of hops.

4 Use the Layout slider to indicate whether greater speed or better accuracy is 
more important. 

5 Select other options in the dialog box to control the appearance of the 
topology map.

See Table 8 for a description of the options available.

6 Click Apply.

7 Click OK.

8 From the Optivity Switch Manager menu bar, choose Actions > Discover 
Map.

The topology map is displayed.

Table 8 describes the items in the Preferences dialog box.

Table 8   Preferences dialog box items

Section Item Description

Discovery Seed Address(es) The IP address(es) of one or more devices 
that Optivity Switch Manager queries using 
SNMP to start the discovery process. For a list 
of supported devices, see Installing Optivity 
Switch Manager, Release 1.1.0.0.
Note: If the devices you want to monitor and 
configure are not connected to the same 
network, you can specify multiple seed 
addresses, separated by commas. The 
separate networks do not appear to be 
connected in the network topology map.

Max Hops  The number of hops, between 1 and 20, that 
a data packet travels from one router or 
intermediate point to another in the network. 
(Default is 5 hops.)

Restrict Discovery Opens the Restrict Discovery dialog box to 
restrict device discovery to only the devices in 
the subnets entered. Refer to “Restricting 
discovery” on page 51 for more information.
Using Optivity Switch Manager, Release 1.1.0.0
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Map Layout Drag the slider to the right (better) or to the left 
(faster) to indicate how you want Optivity 
Switch Manager to lay out devices in the 
network topology map. Refer to “Layout slider” 
on page 52 for more information.

Show Device by Determines how a device is identified in the 
network topology map. The selections are: 
• HostName 

• SysName 
• IP Address (Default)

Trim HostName Domains Truncates Internet host name domains.

Example: nortelnetworks.com becomes 
nortelnetworks

Non-highlighted area Allows you to select an option for viewing 
inactive devices. The options are:
• Dimmed–Non-highlighted items are 

shaded. (Default)

• Invisible–Removes non-highlighted items 
from the topology map.

Automatically Save on Exit If checked, the current network topology map 
is automatically saved to the default.topo file.

Automatically Relayout 
after discovery

If checked, the network topology map is 
adjusted for better viewing as it is loaded in 
Optivity Switch Manager.

Table 8   Preferences dialog box items (continued)

Section Item Description
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Restricting discovery

You can restrict the discovery process to devices on specified subnets. Use the 
Restrict Discovery dialog box to enter IP subnets that are available for discovery 
by Optivity Switch Manager. Only devices on a listed subnet are displayed in the 
Optivity Switch Manager contents pane.

To restrict discovery to certain subnets:

1 From the Optivity Switch Manager menu bar, choose Edit > Preferences.

2 Click Restrict Discovery.

The Restrict Discovery dialog box opens (Figure 12).

SNMP Retry Count The number of times, between 0 and 5, 
Optivity Switch Manager tries to connect to a 
device using SNMP. (The default is 1.)

Timeout The amount of time, between 3 and 10 
seconds, Optivity Switch Manager waits 
before trying to connect to a device again. 
(The default is 5.)

Max Outstanding 
Requests

The number of SNMP requests, between 20 
and 250, that Optivity Switch Manager 
maintains as open or outstanding. (The 
default is 100.)

Trace If checked, additional SNMP information is 
written to the Optivity Switch Manager error 
log, and can provide assistance in 
troubleshooting.
Note: Selecting Trace could slightly slow 
down performance as extra information is 
gathered.

Table 8   Preferences dialog box items (continued)

Section Item Description
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Figure 12   Restrict Discovery dialog box

3 Click Insert.

A new row containing 0.0.0.0 appears under the To Subnet heading.

4 Click the row containing 0.0.0.0 and type the subnet address.

5 Click Close.

Layout slider

Use the layout slider to improve the readability of the topology map. It adjusts the 
layout of the devices in the network topology using the Spring algorithm, which 
balances the distances between devices and minimizes the number of crossing 
lines.

To use the layout slider:

1 Choose Edit > Preferences.

The Preferences dialog box opens (Figure 11 on page 48).

2 In the Map area, slide the ruler between faster and better to adjust the layout 
display.

Optivity Switch Manager retains the locations of nodes until you rediscover 
the network. 

3 Click Apply.
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4 To resdiscover the network topology map with new layout, do one of the 
following:

• From the Optivity Switch Manager menu bar, choose Actions > Discover 
Map.

• On the Optivity Switch Manager toolbar, click Discover Network.

Accessing devices within different SNMP communities

SNMP community passwords can provide a level of protection by limiting access 
to devices. In Optivity Switch Manager, you can access subnets with different 
communities by adding the correct SNMP passwords in the Communities dialog 
box. SNMP devices, which include those devices supported by Optivity Switch 
Manager, typically have two passwords or communities for read and write 
operations on that device. The two passwords are “public” (open access) and 
“private” (restrictive access).

By default, Optivity Switch Manager reads an ASCII file (snmpcomm.properties) 
that contains one entry. That entry allows Optivity Switch Manager to access all 
devices in the discovered network using “public” as the community password for 
read operations and “private” as the password for write operations. If devices 
contain a different SNMP community password, you cannot access them unless 
you know their passwords and enter those password into the Optivity Switch 
Manager snmpcomm.properties file.

To assign a different SNMP community password to a group or single device:

1 From the Optivity Switch Manager menu bar, choose Edit > Communities.

The Communities dialog box opens (Figure 13).
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Figure 13   Communities dialog box

2 Click Insert.

An empty row is added to the table.

3 Click on the empty row and enter the IP address and communities.

4 Click Save.

The changes are saved to the snmpcomm.properties file.

Table 9 describes the Communities fields in the dialog box.

Table 9   Communities dialog box fields

Fields Descriptions

Address The subnet address of a group of devices or the IP address 
of a single device. (Default is 0.0.0.0 to include all devices.)
Note: Optivity Switch Manager uses zero (0) as a wildcard 
to associate SNMP communities with groups of devices. 
You can place a zero anywhere in the IP address. For 
example, the address 10.10.0.0 refers to all addresses in 
the 10.10. subnet.

Read The level of permission to view or read configuration 
information on a group of devices or single device. 

The community string default is public (open access)

Write The level of permission to change configuration information 
on a group of devices or single device. 

The default community string is private (restrictive access)
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Chapter 4
Using VLAN Manager 

VLAN Manager manages Spanning Tree Groups (STGs) and VLANs across 
devices in a network. Optivity Switch Manager is the starting point for VLAN 
Manager, and Optivity Switch Manager must be open to use VLAN Manager.

This chapter describes using VLAN Manager to manage VLANs on Passport and 
BayStack switches. The chapter includes the following information:

• What is VLAN Manager?, next

• Starting VLAN Manager (page 57)

• VLAN Manager window (page 57)

• Using VLAN Manager (page 63)

• Managing spanning tree groups (STGs) (page 79)

• Managing a VLAN (page 82)

• Highlighting STGs and VLANs in the Optivity Switch Manager contents 
pane (page 93)

What is VLAN Manager?

VLAN Manager enables you to manage VLAN and STG configurations across a 
single device or multiple devices. It supports the rcVlan and rcStg MIBs.

VLAN

A VLAN is a collection of ports on one or more switches that defines a broadcast 
domain. You can assign ports to a VLAN or you can create a policy VLAN, which 
determines the port’s membership in the VLAN based on the traffic entering that 
port. For example, in an IP subnet-based VLAN, the port belongs to the VLAN 
only if the traffic passing through the port is on the specified IP subnet.
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You control path redundancy for VLANs by implementing the Spanning Tree 
Protocol (STP). 

Spanning Tree Protocol

As defined in the IEEE 802.1D standard, the Spanning Tree Protocol detects 
and eliminates logical loops in a bridged or switched network. When multiple 
paths exist, the spanning tree algorithm configures the network so that a bridge or 
switch uses only the most efficient path. If that path fails, the protocol 
automatically reconfigures the network to make another path active, thus 
sustaining network operations.

The collection of ports in one spanning tree is called a spanning tree group (STG) 
and a network may include multiple instances of STGs. All the devices supported 
by Optivity Switch Manager support at least one STG. The Passport 1000 Series 
switch and the Passport 8600 modules support multiple spanning trees, thus 
multiple spanning tree groups.

Table 10 lists the maximum number of STGs and VLANs supported by the 
different switches.

For more information about VLANs and Spanning Tree Protocol, refer to 
Networking Concepts for the Passport 1000 Series Routing Switch Release 2.0 
and Networking Concepts for the Passport 8000 Series Routing Switch.

Table 10   Maximum STGs and VLANs supported by switches

Switch
Maximum
number of STGs

Maximum
number of VLANs

Passport 1000 Series switch 25 124

Passport 8100 modules 1 2000

Passport 8600 modules 25 1979

BayStack 350/410/450 switches 1 64

Business Policy Switch 2000 1 64
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VLAN Manager features

VLAN Manager allows you to:

• Configure and monitor VLANs and STGs across one or multiple devices.

• View and edit port membership information: ports not belonging to an STG, 
or ports belonging to multiple STGs, individual routing ports and brouter 
ports.

• View Spanning Tree configuration information In the Optivity Switch 
Manager contents pane, such as which ports are blocking or forwarding. You 
can also see which device is the root of the Spanning Tree configuration.

The following sections describe the VLAN Manager window and the 
management functions available.

Starting VLAN Manager

To start VLAN Manager:

• From the Optivity Switch Manager menu bar, choose Tools > VLAN 
Manager.

• On the keyboard, press [F2].

• On the Optivity Switch Manager toolbar, click VLAN Manager.

The VLAN Manager window opens (Figure 14).

VLAN Manager window

The VLAN Manager window (Figure 14) contains the parts described in Table 11.

Do one of the following:
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Figure 14   VLAN Manager window

Table 11 describes the parts of the VLAN Manager window.

Menu bar

The menu bar provides menus and commands for operating VLAN Manager.

Table 11   VLAN Manager window parts

Part Description

Title bar Displays the submanager name.

Menu bar Provides access to all VLAN Manager commands.

Toolbar Provides quick access to commonly-used VLAN Manager commands.

Navigation pane Provides a navigation tree showing VLAN Manager network folder 
resources.

Contents pane Displays information selected in the navigation pane.

Status bar Displays status information, including the type of device highlighted 
and command status.

Title bar

Menu bar

Toolbar

Navigation pane

Status bar

Contents pane
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Table 12 lists the VLAN Manager menus and commands.

Table 12   VLAN Manager menus and commands

Menu Command Shortcut Key Description

File Reload [Ctrl]+R Reloads the VLAN Manager 
information.

Save 
Diagnostic 
Info

[Ctrl]+S Saves diagnostic information about the 
STGs and VLAN discovered.

Print [Ctrl]+P Opens the Print dialog box, where you 
enter print parameters.

Close Closes the VLAN Manager window.

Edit Undo 
Changes

[Ctrl]+Z Reverses any changes you made to an 
item or field.

Copy [Ctrl]+C Copies the contents of a selected cell.

Paste [Ctrl]+V Pastes the cell contents to a new 
location.

Insert [Insert] Opens the Insert dialog box, where you 
insert an STG or VLAN on selected 
devices.

Delete [Del] Removes a selection and displays a 
message to confirm deletion of the 
selected VLAN.

Apply 
Changes

[Ctrl]+A When you have made changes to your 
VLAN configuration, this command 
applies these changes to the devices in 
the network.

Edit MAC 
Address

Allows you to insert the text file 
containing the MAC addresses for 
MAC-based VLANs.

Find [Ctrl]+F Opens the Find dialog box, where you 
set parameters to find matching entries 
in your network.

View Highlight 
Topology

Highlights the VLAN topology map in the 
Optivity Switch Manager contents pane.

Audit Queries the network configuration to 
report any discrepancies.
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Toolbar

For information about the toolbar buttons available in VLAN Manager, refer to 
Table 5 on page 36.

Navigation pane

The VLAN Manager navigation pane (Figure 15) is located on the left side of the 
window. It contains a network folder for each STG found in the network. When 
you select an STG folder, the tree expands to display the STG configuration 
information and then lists the VLANs associated with that STG.

In the navigation pane, select the folder for which you want to view STG or 
VLAN information, or choose Edit > Print to print the navigation tree.

Help Using Opens a Web browser and loads the 
Help files.

Online 
Support

Opens a Web browser that loads the 
Nortel Networks Customer Support Web 
page.

About VLAN 
Manager

Displays information about VLAN 
Manager.

Table 12   VLAN Manager menus and commands (continued)

Menu Command Shortcut Key Description
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Figure 15   VLAN Manager navigation pane

Contents pane

When you select a network resource in the navigation pane, a table opens in the 
contents pane (Figure 16).

Figure 16   Default (1) folder view in the contents pane
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To view the VLAN information in the contents pane:

The example in Figure 16 shows the VLAN membership information for the 
Default VLAN. The Default (1) folder opens in the contents pane when you 
select Default (1) from the navigation tree.

Status bar

The VLAN Manager status bar (Figure 14 on page 58) is located at the bottom of 
the VLAN Manager window and contains two fields. Table 13 describes the 
VLAN Manager status bar fields.

Finding network resources

You can locate an entry in a field that contains a particular item of information, 
such as text, seed address, or VLAN ID number.

To find a network resource:

1 Click any device in the navigation tree or contents pane, and do one of the 
following:

• From the VLAN Manager menu bar, choose Edit > Find.

In the navigation pane, select an STG or VLAN icon.

Table 13   VLAN Manager status bar fields

Field Description

Message Located on the left, the message field displays information about VLAN 
manager operations.

Icon Located on the right, the icon field provides a legend for different types of 
VLANs found in the network:
• port–a VLAN in which the ports are explicitly assigned to the VLAN.
• subnet–a VLAN in which ports are dynamically added to the VLAN 

based on source IP subnet.
• protocol–a VLAN in which ports are dynamically added to the VLAN 

based on a network protocol.

• mac–a VLAN in which ports are dynamically added to the VLAN 
based on the source MAC address.
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• On the VLAN Manager toolbar, click Find.

The Find dialog box opens (Figure 17).

Figure 17   Find dialog box

2 In the Find text box, type the text or number for your search.

3 In the In section, click the Tree option to search the navigation tree, or click 
the Table option to search the contents pane.

4 Click Next.

VLAN Manager starts its search and highlights the first match that it finds or 
displays a message that it found no matches.

5 If a first match was found, click Next to find each subsequent match, or click 
Previous to go back to your last match.

Using VLAN Manager

Using VLAN Manager, you can monitor, configure, and troubleshoot STGs and 
VLANs found in the network.

This section includes the information about the following topics:

• Port membership (ports not belonging to STGs or ports belonging to multiple 
STGs)

• Viewing spanning tree groups (STGs)

• VLAN ports
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Port membership

In the navigation pane, the top four icons represent the following types of port 
memberships:

• Unassigned

• Tagging

• Isolated Routing Port (IRP)

• Bridge Routing (brouter ports)

Table 14 describes the port membership types.

Viewing the unassigned ports

To view the table associated with the unassigned ports:

Table 14   Port membership types and STGs

Icon Port type Description

Unassigned Port that do not belong to any STG. If no devices in the 
network contain unassigned ports, a table does not open 
in the contents pane.

Tagging Port that has tagging enabled and can belong to multiple 
STGs. If a tagged frame is received on a tagged port, with 
a VLAN ID specified in the tag, the switch directs it to that 
VLAN, if it is present.

Isolated Routing 
Port (IRP)

Port that can only route IP packets and does not belong to 
any STG or VLAN.
Note: IRPs are applicable only to the Passport 1000 
Series switch.

Bridge Routing 
(brouter ports)

Port that can route IP packets as well as bridge all 
nonroutable traffic. The routing interface is not subjected 
to the Spanning Tree Protocol. 

Note: Bridge routing ports, or brouter ports, are available 
only on the Passport 1000 Series switch and the Passport 
8600 switch.

In the navigation pane, select Unassigned.
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The Unassigned Ports table opens in the contents pane (Figure 18). Because 
there are no unassigned ports in the discovered network, the table is empty.

Figure 18   Unassigned Ports table

Table 15 describes the Unassigned Ports table fields.

Viewing tagged Ports

To view the devices and ports associated with tagged ports:

The Tagging Ports table opens in the contents pane (Figure 19).

Table 15   Unassigned Ports table fields

Field Description

Device IP address, system name, or host name of the device.

Ports Ports not currently assigned to an STG.

In the navigation pane, select Tagging.
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Figure 19   Tagging Ports table

Table 16 describes the fields in the Tagging Ports table.

Viewing isolated router ports (IRPs) 

To view IRPs on Passport 1000 Series switches:

The Isolated Routing Ports table opens in the contents pane (Figure 20).

Table 16   Tagging Ports table fields

Field Description

Device IP address, system name, or host name of the device.

Port Ports on which tagging is enabled.

VlanIds VLAN ID(s) of which the port is a member.

In the navigation pane, select Isolated Routing.
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Figure 20   Isolated Routing Ports table

Table 17 describes the fields in the Isolated Routing Ports table.

Viewing bridge routing Ports

To view bridge routing (brouter) ports on Passport 1000 Series switches and 
Passport 8000 Series switches:

The Bridge Routing Ports table opens in the contents pane (Figure 21).

Table 17   Isolated Routing Ports table fields

Field Descriptions

Device IP address, system name, or host name of the device.

Ports Ports that route only IP packets.

In the navigation pane, select Bridge Routing.
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Figure 21   Bridge Routing Ports table

Table 18 describes the fields in the Bridge Routing Ports table.

Viewing spanning tree groups (STGs)

All devices supported by Optivity Switch Manager support the IEEE 802.1D 
Spanning Tree Protocol and at least one instance of a Spanning Tree Group. Refer 
to Table 10 on page 56 for the maximum STGs supported by each switch.

To view an STG:

The folder expands to show four icons representing types of information 
available about the STG and a list of VLANS in the STG (Figure 22).

Table 18   Bridge Routing Ports table fields

Field Descriptions

Device IP address, system name, or host name of the device.

Ports Port numbers of the port on which frames are received.

Click the folder for the STG you want to view.
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Figure 22   STG folder in the VLAN Manager navigation pane

Table 19 describes the STG icons displayed in the VLAN Manager navigation 
pane.

Members

To view the ports that are members of the STG:

The Members table opens in the contents pane (Figure 23).

Table 19   STG information icons

Icon Name Representation

Members Devices and ports that are part of the STG.

Config STG configuration information.

Status STG status information, including STG topology 
change information.

Root Devices that are the STG root.

In the navigation pane, select Members.
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Figure 23   Spanning tree group members table

Table 20 describes the fields in the Members table.

Adding port members

To add ports to an STG:

1 In the Members table, select a device in the list.

2 Double-click in the PortMembers cell for the device to which you want to add 
port membership.

The PortMembers dialog box opens (Figure 24).

Table 20   Members table fields

Field Description

Device IP address, system name, or host name of the device.

PortMembers Ports on the device that are members of the STG.
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Figure 24   PortMembers dialog box

3 Select the port number(s) or click All for all the ports.

4 Click Ok.

Viewing and configuring STG parameters

You can view and configure STG parameters.

To view the configuration information:

The Configuration table opens (Figure 25) in the contents pane.

In the navigation pane, select Config.
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Figure 25   Configuration table

Table 21 describes the fields in the Configuration table.

Table 21   Configuration table fields

Field Description

Device IP address, system name, or host name of the device.

Priority The Spanning Tree Protocol (STP) bridge priority, in decimal. 
The range is 0 (highest priority) to 65535 (lowest priority). The 
default is 32768.

BridgeMaxAge The value in hundredths of a second that all bridges use for 
MaxAge when this bridge is acting as the root. 
Note: The 802.1D-1990 standard specifies that the range for 
this parameter is related to the value of dot1dStp\Time. 
The default is 2000 (20 seconds).

BridgeHelloTime The value in hundredths of a second that all bridges use for 
Hello Time when this bridge is acting as the root. The granularity 
of this timer is specified by the IEEE 802.1D-1990 standard to 
be in increments of 1/100 of a second. The default is 200 
seconds.

BridgeForwardDelay The value in hundredths of a second that all bridges use for 
Forward Delay when this bridge is acting as the root. The default 
is 1500 (15 seconds).

EnableStp Enables or disables the spanning tree algorithm for the spanning 
tree group.

StpTrapEnable Enables or disables SNMP traps to be sent to trace receiver 
every time an STP topology change occurs.
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Status group

Use the read-only Status table to view the status of the Spanning Tree Protocol for 
each STG that is associated with the network.

To view the Status table:

The Status table (Figure 26) opens in the contents pane.

Figure 26   Status table

Table 22 describes the fields in the Status table.

TaggedBpduAddress A MAC address; specifically for tagged BPDUs.

TaggedBpduVlanId The VLAN tag associated with the spanning tree group. This ID 
is used to tag BPDUs through a non-IEEE tagging bridge to 
another Passport switch. 

In the navigation pane, select Status.

Table 21   Configuration table fields (continued)

Field Description
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Root

The read-only Root table displays information about the device acting as root 
within a selected STG.

To view the root table:

The Root table opens in the contents pane (Figure 27).

Table 22   Status table fields

Field Description

Device IP address of the bridge.

NumPorts Number of ports controlled by this bridging entity.

ProtocolSpecification An indication of which version of the Spanning Tree 
Protocol (STP) is operating. The IEEE 802.1d 
implementations display ieee8021d.

TimeSinceTopologyChange Time in hundredths of a second since the last time a 
topology change was detected by the bridge entity or STG.

TopChanges The number of topology changes detected by this bridge 
since the management entity was last reset or initialized. 

MaxAge Maximum age of STP information learned from the network 
on any port before it is discarded, in units of hundredths of 
a second. This is the actual value that the bridge is 
currently using. The default value is 2000 (20 seconds).

HelloTime Amount of time in hundredths of a second between 
transmission of configuration bridge protocol data units 
(BPDUs) by this device on any port when it is the root of 
the spanning tree. The default value is 200 (2 seconds).

HoldTime Time interval in hundredths of a second during which no 
more than two configuration BPDUs are transmitted by this 
device. The default value is 100 (1 second).

ForwardDelay Time interval in hundredths of a second that controls how 
fast a port changes its spanning state when moving toward 
the Forwarding state. This value determines how long the 
port stays in each of the Listening and Learning states, 
which precede the Forwarding state. This value is also 
used when a topology change is detected and is under 
way, to age all dynamic entries in the Forwarding 
Database. The default value is 1500 (15 seconds).

In the navigation pane, select Root.
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Figure 27   Root table

Table 23 describes the fields on the Root table.

Default VLAN 

Passport 8000 Series switches, Passport 1000 Series switches, BayStack 350/410/
450 switches, and the Business Policy Switch 2000 are factory configured with all 
ports in a port-based VLAN called the default VLAN. The VLAN ID of the 
default VLAN is always 1, and it is always a port-based VLAN. You cannot delete 
the default VLAN, although you can remove ports from it.

Table 23   Root table fields

Field Description

Device IP address of a device in the STG.

BridgeAddress MAC address used by this bridge when it must be identified in a 
unique fashion.

DesignatedRoot Bridge identifier of the root of the spanning tree as determined by 
the Spanning Tree Protocol as executed by this device. This value 
is used as the Root Identifier parameter in all configuration BPDUs 
originated by this device.

RootCost Cost of the path to the root as seen from this bridge.

RootPort Port number of the port that offers the lowest cost path from this 
bridge to the root bridge.
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To view the Default Ports table:

The Default VLAN table opens in the contents pane (Figure 28).

Figure 28   Default VLAN table

Table 24 describes the fields in the Default VLAN table.

From the navigation tree, select Default(1).

Table 24   Default VLAN table fields

Field Description

Device IP address, system name, or host name of the device.

PortMembers Ports that are assigned to the VLAN.

HighPriority In a Passport 1000 Series switch, you can select HighPriority mode 
for all traffic in the VLAN.

QosLevel In a Passport 8000 Series switch, you can set the Quality of Service 
level for traffic in the VLAN to a level between 1 and 8.

DsField In a Passport 8000 Series switch, you can set the Differentiated 
Services field for traffic in the VLAN to a level between 1 and 54.
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VLAN ports

Ports in a VLAN are always members of a spanning tree group (STG). A VLAN 
can include all the ports in a given STG, and there can be multiple VLANs in an 
STG, but a VLAN will never have more ports than exist in the STG.

In an STG, VLAN information is displayed in the contents pane when that VLAN 
is selected.

The icon that precedes the VLAN name identifies the type of VLAN:

• Port

• Subnet

• Protocol

• Mac

To view VLANs:

IfIndex Logical interface index assigned to the VLAN. This value can be in 
one of the following ranges:
• Passport 1000 Series switch: 257 to 512
• Passport 8000 Series switch: 2049 to 4096

Note: This field does not apply to BayStack or Business Policy Switch 
2000 switches.

IpAddress IP address, if any, assigned to the VLAN for routing.

Note: Not all VLAN types are available on all devices that Optivity 
Switch Manager supports. Of these four types of VLANs, Passport 8100 
switches and the Business Policy Switch 2000 support only port-based 
or protocol-based VLANs. BayStack 350/410/450 switches support only 
port-based VLANs. Refer to the documentation that was shipped with 
your switch for more information.

In the navigation pane, select a VLAN.

Table 24   Default VLAN table fields (continued)

Field Description
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The VLAN table opens (Figure 29) in the contents pane.

Figure 29   VLAN table

Table 24 on page 76 describes the fields in the VLAN table.
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Managing spanning tree groups (STGs)

You can edit STG and STG membership information to manage STGs in any of 
the following ways:

• Creating a spanning tree group

• Editing a spanning tree group

• Deleting a spanning tree group

Creating a spanning tree group

On a Passport 1000 Series switch or a Passport 8600 switch, you can create new 
STGs. The BayStack switches and the Business Policy Switch 2000 support only 
one STG per switch.

To create a new spanning tree group:

1 From the navigation tree, highlight the first Network folder and do one of the 
following:

• From the VLAN Manager menu bar, choose Edit > Insert.

• On the VLAN Manager toolbar, click Insert.

The New STG dialog box opens (Figure 30).
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Figure 30   New STG dialog box

2 Insert values or select options in the option boxes.

3 Click Ok.

Table 25 describes the items in the New STG dialog box.

Table 25   New STG dialog box items

Item Description

Id A number between 1 and 25 that identifies the new spanning tree 
group (STG) configured on the network.

TaggedBpduAddress A MAC address, specifically for tagged BPDUs.

TaggedBpduVlanId The VLAN tag associated with the STG. This ID is used to tag 
BPDUs through a non-IEEE tagging bridge to another Passport 
or BayStack switch.

Priority STP bridge priority, in decimal. The range is 0 (highest priority) to 
65535 (lowest priority). The default is 32768.

BridgeMaxAge Value in hundredths of a second that all bridges use for MaxAge 
when this bridge is acting as the root. 
Note: The 802.1D-1990 standard specifies that the range for this 
parameter is related to the value of dot1dStpBridgeHelloTime. 
The default is 2000 (20 seconds).
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Editing a spanning tree group

To edit a spanning tree group:

1 Select an STG folder.

2 In the STG table in the contents pane, click the item that you want to edit.

The field is highlighted, and you can edit directly in the table.

3 Type information in the text boxes, or select from a list.

The changes appear in bold.

4 On the VLAN Manager toolbar, click Apply Changes.

Deleting a spanning tree group

To delete a spanning tree group:

1 In the navigation pane, select an STG folder except STG 1, and do one of the 
following:

• From the VLAN Manager menu bar, choose Edit > Delete.

• On the VLAN Manager toolbar, click Delete.

BridgeHelloTime Value in hundredths of a second that all bridges use for Hello 
Time when this bridge is acting as the root. The granularity of this 
timer is specified by the IEEE 802.1D-1990 standard to be in 
increments of 1/100 of a second. The default is 200 seconds.

BridgeForwardDelay Value in hundredths of a second that all bridges use for Forward 
Delay when this bridge is acting as the root. The default is 1500 
(15 seconds).

Enable Stp Enables or disables the spanning tree algorithm for the spanning 
tree group.

Enable Stp Traps Enables SNMP traps to be sent to trace receiver every time an 
STP topology change occurs.

On All Devices When checked, selects all devices listed in the list. Otherwise, 
select the individual devices to be added to the STG.

Table 25   New STG dialog box items (continued)

Item Description
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The Delete dialog box (Figure 31) opens, asking you to confirm the deletion 
of the STG.

Figure 31   Delete dialog box

2 Do one of the following:

• Click Yes to confirm the deletion and return to the table view.

• Click No to cancel the deletion and return to the table view.

Managing a VLAN

This section contains information about common operations you can perform 
when managing VLANs with VLAN Manager.

Creating a VLAN

When you create VLANs using VLAN Manager, follow these rules:

• VLANs must have unique VLAN IDs and names.

• Trunk (tagged) ports can belong to multiple VLANs and multiple spanning 
tree groups. 

• A VLAN cannot belong to multiple spanning tree groups.

Note: Multiple STGs are supported only on Passport 1000 and Passport 
8000 Series switches.
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• An access (untagged) port can belong to one and only one port-based VLAN 
or it can belong to one and only one policy-based VLAN for the given 
protocol.

• If you enable tagging on a port that is in a VLAN, the spanning tree group 
configuration for that port is lost.

• A frame’s VLAN membership is determined by the following order of 
precedence: 

— VLAN ID

— Source MAC-based VLAN

— IP subnet-based VLAN

— Protocol-based VLAN

— Port-based VLAN

Creating a port-based VLAN

To create a port-based VLAN:

1 In the navigation pane, select an STG.

2 Do one of the following:

• From the menu bar, choose Edit > Insert.

• On the toolbar, click Insert.

The New VLAN dialog box opens (Figure 32).
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Figure 32   New VLAN dialog box

3 Type the VLAN ID.

The value can be from 1 to 4094, as long as it is not already in use. (The 
default VLAN has a VLAN ID of 1.)

4 Type the VLAN name (optional).

If no name is entered, a default is created.

5 For a Passport 8600 switch, select the QoS Level (optional)

6 For a Passport 8600 switch, type the Differentiated Services (DS) Field 
(optional).

7 For a Passport 1000 Series switch, specify if the VLAN traffic will be tagged 
as High Priority (optional).

8 In the Type option, select byPort.

Other items in the dialog box that apply to a port-based VLAN are activated.
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9 Select the device to be configured on the VLAN by doing one of the 
following:

• Select from the device list.

• Click On All Devices to select all devices in the list.

10 Click Ok.

Table 26 describes the items in the New VLAN dialog box.

Creating a source IP subnet-based VLAN

Source IP subnet-based VLANs are supported only on Passport 1000 Series and 
Passport 8000 Series switches.

To create a source IP subnet-based VLAN:

1 In the navigation pane, select an STG.

2 Do one of the following:

• From the menu bar, choose Edit > Insert.

• On the toolbar, click Insert.

Table 26   New VLAN dialog box items

Item Description

Id A number between 1 and 4,094 that identifies the new VLAN 
configured on the network.

Name Name given to the VLAN.

QosLevel For a Passport 8000 Series switch, you can set the Quality of 
Service level for traffic in the VLAN to a level between 1 and 8.

DsField For a Passport 8000 Series switch, you can set the Differentiated 
Services field for traffic in the VLAN to a level between 1 and 54.

High Priority For a Passport 1000 Series switch, you can select HighPriority 
mode for all traffic in the VLAN.

Type Type of VLAN:
• Port-based VLAN

• Source IP subnet-based VLAN
• Protocol-based VLAN
• Source MAC address-based VLAN

On All Devices Selects all devices in the list.
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The New VLAN dialog box opens (Figure 33).

Figure 33   New VLAN dialog box with bySubnet selected

3 Type the VLAN ID.

The value can be from 1 to 4094, as long as it is not already in use. (The 
default VLAN has a VLAN ID of 1.)

4 Type the VLAN name (optional).

If no name is entered, a default is created.

5 For a Passport 8600 switch, you the QoS Level (optional)

6 For a Passport 8600 switch, type the Differentiated Services (DS) Field 
(optional).

7 For a Passport 1000 Series switch, specify if the VLAN traffic will be tagged 
as High Priority (optional).

8 In the Type option, select bySubnet.

Other items in the dialog box that apply to a subnet-based VLAN are 
activated.

9 In the Subnet text box, type the source IP subnet address.
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10 In the Mask text box, type the IP subnet mask.

11 Select the device to be configured on the VLAN by doing one of the 
following:

• Select from the device list.

• Click On All Devices to select all devices in the list.

12 Click Ok.

13 Do one of the following:

• From the VLAN Manager menu bar, choose Apply Changes.

• On the VLAN Manager toolbar, click Apply Changes.

Creating a protocol-based VLAN

To create a protocol-based VLAN:

1 In the navigation pane, select an STG.

2 Do one of the following:

• From the menu bar, choose Edit > Insert.

• On the toolbar, click Insert.

The New VLAN dialog box opens (Figure 34).
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Figure 34   New VLAN dialog box with byProtocolId selected

3 Type the VLAN ID.

The value can be from 1 to 4094, as long as it is not already in use. (The 
default VLAN has a VLAN ID of 1.)

4 Type the VLAN name (optional).

If no name is entered, a default is created.

5 For a Passport 8600 switch, select the QoS Level (optional)

6 For a Passport 8600 switch, type the Differentiated Services (DS) Field 
(optional).

7 For a Passport 1000 Series switch, specify if the VLAN traffic will be tagged 
as High Priority (optional).

8 In the Type box, select byProtocolId.

Other items in the dialog box that apply to protocol-based VLANs are 
activated.
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9 In the ProtocolId box, select the protocol. 

If you select UsrDefined, refer to “User-defined protocols in a protocol-based 
VLAN” on page 89 for more information.

10 Select the device to be configured on the VLAN by doing one of the 
following:

• Select from the device list.

• Click On All Devices to select all devices in the list.

11 Click Ok.

12 In the Ports table, specify the port membership by clicking on one or all of the 
following columns and specifying ports:

• ActiveMember

• PotentialMembers

• StaticMembers

• NotAllowedToJoin

13 Do one of the following:

• From the VLAN Manager menu bar, choose Apply Changes.

• On the VLAN Manager toolbar, click Apply Changes.

User-defined protocols in a protocol-based VLAN

You can create a protocol-based VLAN with a user-defined protocol for 
integration into existing networks where nonstandard protocols are used. 

In the UserDefinedPId text box, enter the PID of the protocol in the format 0x 
(protocol type in decimal value). 

• For a Passport 8600 switch and Passport 1000 Series switch, the 16-bit PID 
assigned to a protocol-based VLAN specifies either an Ethertype, a DSAP/
SSAP, or a SNAP PID, depending on whether the frame encapsulation is 
Ethernet 2, 802.2, or LLC-SNAP, respectively. 

• For a Passport 8100 switch, the 16-bit PID assigned to a protocol-based 
VLAN specifies only an Ethertype for Ethernet 2 frame encapsulation.
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Refer to the section on user-defined protocols in Networking Concepts for the 
Passport 1000 Series Routing Switch Release 2.0 and Networking Concepts for 
the Passport 8000 Series Routing Switch for more information about this topic or 
to see the actual values and how they are assigned.

The following PIDs are not valid:

• PID0x0000 through 0x05dc: overlap with the 802.3 frame length

• PIDs of predefined protocols (for example, IP, IPX, AppleTalk)

• PID 0x8100: reserved by 802.1Q to identify tagged frames

• PID0x9000: used by the diagnostic loopback frames

• PID0x8808: used by 802.3x pause frames

• PID0x4242: overlaps with the BPDU DSAP/SSAP

Creating a source MAC address-based VLAN

To create a source MAC address-based VLAN:

1 In the navigation pane, select an STG.

2 Do one of the following:

• From the menu bar, choose Edit > Insert.

• On the VLAN Manager toolbar, click Insert.

The New VLAN dialog box opens (Figure 35).
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Figure 35   New VLAN dialog box with bySrcMac selected

3 Type the VLAN ID.

The value can be from 1 to 4094, as long as it is not already in use. (The 
default VLAN has a VLAN ID of 1.)

4 Type the VLAN name (optional).

If no name is entered, a default is created.

5 For a Passport 8600 switch, select the QoS Level (optional)

6 For a Passport 8600 switch, type the Differentiated Services (DS) Field 
(optional).

7 For a Passport 1000 Series switch, specify if the VLAN traffic will be tagged 
as High Priority (optional).

8 In the Type option, select bySrcMac.

Other items in the dialog box that apply to source MAC address-based 
VLANs are activated.
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9 Select the device to be configured on the VLAN by doing one of the 
following:

• Select from the device list.

• Click On All Devices to select all devices in the list.

10 Click Ok.

11 Select the newly created MAC-based VLAN, and choose Edit > Edit Mac 
Addresses. 

The Edit Mac - VLAN dialog box opens (Figure 36).

Figure 36   Edit Mac - VLAN dialog box

12 Select Add From File and enter the file name of the text file containing the 
MAC addresses to added to the new MAC-based VLAN. 

You can create this file earlier and remember where you saved the text file. 
You can use colons (:) or dashes (-) to delineate the MAC address.

13 Click Close.

14 Click Refresh.

Deleting a VLAN

To delete a VLAN:

1 In the navigation pane, select a VLAN and do one of the following:

• From the VLAN Manager menu bar, choose Edit > Delete.
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• On the VLAN Manager toolbar, click Delete.

The Delete dialog box opens (Figure 31 on page 82).

2 Click Yes.

Highlighting STGs and VLANs in the Optivity Switch 
Manager contents pane

Optivity Switch Manager provides dynamic discovery of active STG devices in a 
network. From Optivity Switch Manager, you can view the following 
information:

• Which ports in the network are configured as unassigned, tagging, or isolated 
routing ports (IRPs) and brouter ports

• Which ports are assigned to a particular spanning tree group (STG)

• Which device is the root of an STG, and which ports are in the forwarding and 
blocking states.

• Which ports are members of a VLAN or multiple VLANs.

Viewing VLAN members in Optivity Switch Manager

To view the members of a VLAN in Optivity Switch Manager:

1 In the navigation pane, choose a VLAN.

The Ports table opens in the VLAN Manager contents pane.

2 From the VLAN Manager menu bar, choose View > Highlight Topology.

3 Return to the Optivity Switch Manager window.

The highlighted topology view opens in the Optivity Switch Manager 
contents pane.

Figure 37 shows that 10.10.40.170 and 10.10.40.235 are members of 
VLAN-209.
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Figure 37   VLAN topology in the Optivity Switch Manager contents pane

Viewing STG port members

When you select an STG in the VLAN Manager navigation pane, you can view 
the devices and ports associated with that STG in the Optivity Switch Manager 
network topology map. This view can assist you in troubleshooting by identifying 
which ports are already members of the STG selected.

VLAN
members
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To view STG ports:

1 In the VLAN Manager navigation pane, choose an STG Members icon.

The STG Members table opens in the VLAN Manager contents pane.

2 From the VLAN Manager menu bar, choose View > Highlight Topology.

3 Return to the Optivity Switch Manager window.

The devices containing STG ports are highlighted (Figure 38) with a color 
and the device’s IP address. Those device ports that are members of the STG 
are outlined in black.
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Figure 38   Viewing STG port members

Some of the
STG port
members
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Viewing STG root configuration

You can get a quick view of which device is the root of the spanning tree group 
and which ports are in the forwarding and blocking state by selecting the STG root 
icon.

To view STG root configuration in Optivity Switch Manager:

1 In the navigation pane, select an STG Root.

The Root table opens in the contents pane.

2 From the VLAN Manager menu bar, choose View > Highlight Topology.

3 Return to the Optivity Switch Manager window.

The highlighted topology view (Figure 39) opens in the Optivity Switch 
Manager contents pane with the root displayed.

Figure 39   Root topology displayed in the Optivity Switch Manager contents pane

Forwarding

STG Root

port
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In Figure 39, the root of the STG is 10.10.40.153, and the port in forwarding state 
is Port 9 on Slot 1 of 10.10.40.32.

Note: Update the View > Highlight topology periodically to refresh the 
topology display, because ports may change from forwarding to blocking 
and vice versa.
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Chapter 5
Using MultiLink Trunking Manager

MultiLink Trunking is a point-to-point connection that aggregates multiple ports 
so that they logically act like a single port with the aggregated bandwidth. 
Grouping multiple ports into one logical link allows you to achieve higher 
aggregate throughput on a switch-to-switch or server-to-server application.

This chapter describes using MultiLink Trunking Manager to manage single and 
multiple device configurations on switches. The chapter includes the following 
information:

• What is MultiLink Trunking Manager? (next)

• Starting MultiLink Trunking Manager (page 100)

• MultiLink Trunking Manager window (page 101)

• Using MultiLink Trunking Manager (page 106)

• Managing MultiLink Trunks (MLTs) (page 111)

• Highlighting devices and MLT links in Optivity Switch Manager (page 118)

For more information about MLT concepts, refer to Networking Concepts for the 
Passport 8000 Series Routing Switch and Networking Concepts for the Passport 
1000 Series Routing Switch Release 2.0.

What is MultiLink Trunking Manager?

MultiLink Trunking Manager enables you to configure and monitor MultiLink 
Trunks (MLTs) across a single device or two adjacent devices. In MultiLink 
Trunking Manager, you can configure an MLT before you physically connect the 
ports.

Table 27 lists the number of MLTs available with each supported switch type.
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MultiLink Trunking Manager features

MultiLink Trunking Manager supports devices that implement the rcVlan and 
rcMlt MIB groups.

MultiLink Trunking Manager allows you to:

• Create, delete, or modify MLTs across one or two devices.

• View MLT configuration information such as port and MLT membership.

• View MLT links in the network topology map.

Starting MultiLink Trunking Manager

To start MultiLink Trunking Manager:

• From the Optivity Switch Manager menu bar, choose Tools > MultiLink 
Trunking Manager.

• On the keyboard, press [F3].

• On the Optivity Switch Manager toolbar, click the MultiLink Trunking 
Manager toolbar button.

The MultiLink Trunking Manager window opens (Figure 40).

Table 27   Maximum number of MLTs supported in different switches

Switch
Maximum
number of MLTs

Passport 1000 Series switch 8

Passport 8100 switch 6

Passport 8600 switch 32

BayStack 450 switch 6

Business Policy Switch 2000 6

Do one of the following:
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MultiLink Trunking Manager window

The MultiLink Trunking Manager window contains the parts identified in 
(Figure 40).

Figure 40   MultiLink Trunking Manager window

Table 28 describes the parts of the MultiLink Trunking Manager window.

Table 28   MultiLink Trunking Manager window parts

Part Description

Title bar Displays the submanager name.

Menu bar Provides access to all MultiLink Trunking Manager commands.

Toolbar Provides quick access to commonly-used MultiLink Trunking Manager 
commands.

Navigation pane Provides a navigation tree showing MultiLink Trunking Manager 
network folder resources.

Contents pane Displays MultiLink Trunking Manager tables. 

Status bar Displays status information, including discovery information, type of 
node highlighted, and command status.

Title bar
Menu bar

Toolbar

Navigation pane

Status bar

Contents pane
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Menu bar

The menu bar provides menus and commands for operating MultiLink Trunking 
Manager. Many of the commands also have associated shortcut keys. Table 29 
lists the MultiLink Trunking Manager commands.

Table 29   MultiLink Trunking Manager submenus

Menu Command Shortcut key Description

File Reload [Ctrl]+R Reloads the MultiLink Trunking Manager information.

Save 
Diagnostic 
Information

[Ctrl]+S Saves the current MultiLink Trunking Manager information.

Print [Ctrl]+P Opens the Print dialog box, where you enter print parameters.

Close Closes MultiLink Trunking Manager.

Edit Undo 
Changes

[Ctrl]+Z Reverses any changes you made to a record.

Copy [Ctrl]+C Copies the contents of the selected cell.

Paste [Ctrl]+V Pastes the cell contents when you select a new location.

Insert Opens the Insert dialog box, where you insert an MLT on a 
selected device.

Delete Removes a selection and displays a message box to confirm 
deletion of the selected MLT.

Apply 
Changes

Applies changes made to your MLT configuration to the device 
configuration file.

Find [Ctrl]+F Opens the Find dialog box, where you set parameters to find 
matching entries in your network.

View Highlight 
Topology

Highlights MLT items in the Optivity Switch Manager contents 
pane.

Audit Queries the network topology to report any discrepancies.

Help Using Opens a Web browser and loads help files.

Online 
Support

Opens a Web browser that loads the Nortel Networks 
Customer Support Web page.

About 
MultiLink 
Trunking 
Manager

Displays information about MultiLink Trunking Manager.
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Toolbar

The MultiLink Trunking Manager toolbar has the same buttons as Optivity Switch 
Manager and the other submanagers. For information about the toolbar buttons 
available in MultiLink Trunking Manager, refer to Table 5 on page 36.

Navigation pane

MultiLink Trunking Manager displays devices and adjacent devices in a tree 
structure. The MultiLink Trunking Manager navigation tree (Figure 40) is located 
on the left side of the window and contains branches with the IP address of 
devices discovered by Optivity Switch Manager. 

From the navigation tree in the navigation pane, select the folder for which you 
want to view MLT information, or use the Edit > Print command to print the 
navigation tree.

Contents pane

When you choose a folder in the navigation pane, its contents are shown in the 
contents pane.

To view the folder in the contents pane:

In Figure 41, the contents of the 10.10.40.29 folder are displayed as a table in 
the contents pane.

In the navigation pane, select a Network folder.
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Figure 41   Contents pane

Status bar

The MultiLink Trunking Manager status bar (see Figure 40 on page 101) is 
located at the bottom of the MultiLink Trunking Manager window and has two 
fields. Table 30 describes the fields in the MultiLink Trunking Manager status bar.

Table 30   MultiLink Trunking Manager status bar fields

Field Description

Message Located on the left, the message field displays information about the 
following:
• Optivity Switch Manager and submanager operations
• MLT discovery information

Icon Located on the right, the icon field provides a legend for the types of 
MLTs:
• Trunk

• No trunk
• Isolated
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Finding network resources

To find a network resource in the navigation or contents pane:

1 Click any device in the navigation pane or any text box in the contents pane, 
and do one of the following:

• From the MultiLink Trunking Manager menu bar, choose Edit > Find.

• On the keyboard, press [Ctrl]+F.

• On the MultiLink Trunking Manager toolbar, click Find.

The Find dialog box opens (Figure 42).

Figure 42   Find dialog box

2 In the Find text box, type the text or number you are searching for.

3 In the In section, click Tree to search the navigation tree or Table to search the 
contents pane.

4 Click Next.

MultiLink Trunking Manager starts its search and highlights the first match 
that it finds, or displays a message that it found no matches.

5 If a first match was found, click Next to find each subsequent match, or click 
Previous to go back to your last match.
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Using MultiLink Trunking Manager

In the MultiLink Trunking Manager navigation pane, the navigation tree shows 
the IP addresses of discovered devices. Icons associated with IP addresses on the 
branches indicate the following types of MLT:

• Trunk—a switch that links to another device in the network and has MLT 
configurations.

• No trunk—a switch that links to another device in the network but does not 
have an active MLT configured.

• Isolated—a switch connected only to a hub.

Viewing trunk connections

You can view the trunk connections for an MLT and configure new trunks to 
increase bandwidth. 

To view trunk connections:

The Trunk table opens in the contents pane (Figure 43).

In the navigation pane, select a device that is represented by a trunk icon.
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Figure 43   Trunk table

Table 31 describes the fields in the Trunk table.

Table 31   Trunk table fields

Field Description

Device IP address, system name, or host name of the device.

Id Number of the MLT (assigned by MultiLink Trunking Manager).

Name Name given to the MLT.

PortMembers Ports that are assigned to the MLT.

PortType Type of port on the MLT (access or trunk).

VlanIds VLAN(s) to which the ports belong.

Enable Indicates whether the MLT is enabled (true) or disabled (false).

IfIndex Interface index, a number from 96 to 4097, that identifies the MLT to 
the software.
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Viewing no trunk configurations

No trunk configurations are links between two devices that are not an MLT. To 
have an MLT or trunk connection, there must be more than one connection 
between two devices. Often No trunk configurations are single links between two 
devices.

To view No trunk configurations:

The No Trunk table (Figure 44) opens in the contents pane.

Figure 44   No Trunk table

Table 32 describes the fields in the No Trunk table.

In the MultiLink Trunking Manager navigation pane, select a device IP 
address above the IP address represented by a no trunk icon.

Table 32   No Trunk table fields

Fields Description

Device IP address, system name, or host name of the device

Id Number of the MLT.

Name Name given to the MLT.
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Viewing isolated devices

Isolated devices have one or more connections to a hub or bus, but are not 
connected to another switch. 

To view the isolated devices:

The Isolated Device table opens in the contents pane (Figure 45).

PortMembers Ports that are assigned to the MLT.

PortType Type of port on the MLT (access or trunk).

VlanIds VLAN(s) to which the ports belong.

Enable Whether the MLT is enabled (true) or disabled (false).

IfIndex Interface index, a number from 96 to 4097, that identifies the MLT to 
the software.

In the MultiLink Trunking Manager navigation pane, select an isolated 
device.

Table 32   No Trunk table fields (continued)

Fields Description
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Figure 45   Isolated Device table

Table 33 describes the fields in the Isolated Device table.

Table 33   Isolated Device table fields

Field Description

Device IP address, system name, or host name of the device.

Id Number of the MLT.

Name Name given to the MLT.

PortMembers Ports that are assigned to the MLT.

PortType Type of port on the MLT (access or trunk).

VlanIds VLAN(s) to which the ports belong.

Enable Indicates whether the MLT is enabled (true) or disabled (false).

IfIndex Interface index, a number from 96 to 4097, that identifies the MLT to 
the software.
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Managing MultiLink Trunks (MLTs)

This section contains information about the following common operations you 
can perform using MultiLink Trunking Manager:

• Creating an MLT (next)

• Viewing port information (page 115)

• Editing a port on an MLT (page 116)

• Deleting an MLT (page 117)

• Editing an MLT (page 117)

Creating an MLT

To enable an MLT, the device must have more than one connection to another 
device. With MultiLink Trunking Manager, you can create an MLT on a device 
and then physically connect the ports, or you can connect the ports first and then 
configure the MLT.

Creating an MLT with one device 

When you create an MLT with one device, MultiLink Trunking Manager 
considers only the ports that are available on the one device. After you create an 
MLT on one device, you must also configure and connect the ports in the second 
device before enabling the MLT. You cannot configure an MLT on an isolated 
device.

To create a new MLT with one device selected:

1 Select a device from the first (folder) level of the MultiLink Trunking 
Manager navigation pane.

The Device table opens in the contents pane.

2 Do one of the following:

• From the MultiLink Trunking Manager menu bar, choose Edit > Insert.

• On the MultiLink Trunking Manager toolbar, click Insert.

The Insert MLT dialog box opens (Figure 46).
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Figure 46   Insert MLT dialog box — one device selected

Table 34 describes the items in the Insert MLT dialog box.

3 In the Id text box, select the Id number for the MLT.

4 In the Name text box, type the name of the MLT.

5 In the Ports box, select the ports to be added to the MLT.

Inactive ports appear dimmed in the Ports box.

Table 34   Insert MLT dialog box items for a single device

Item Description

Node IP address of the first network device configured on the MLT.

Id Unique identifier for the MLT, which is automatically assigned by 
MultiLink Trunking Manager.

Name User-defined name of the node on the MLT.

Ports Ports enabled on the MLT.

Type One of the following types of MLT:
• Access

• Trunk
The default is Access.

VlanIds VLAN IDs found on the device. 
208963-B



Chapter 5 Using MultiLink Trunking Manager 113

  
6 Select the MLT type option.

The default is Access.

7 In the VlanIds field, select the VLAN IDs that belong to the MLT port.

8 Click Ok.

Creating a new MLT on a pair of devices

You can configure an MLT between two adjacent devices and MultiLink Trunking 
Manager considers port availability, type of port, and current links between both 
devices. You cannot configure an MLT on an isolated device.

To create a new MLT between two devices:

1 Select a device from the second level of the MultiLink Trunking Manager 
navigation pane.

The Trunk table opens in the contents pane (Figure 47).

Figure 47   Trunk table for a pair of devices

2 Do one of the following:

• From the MultiLink Trunking Manager menu bar, choose Edit > Insert.

• On the MultiLink Trunking Manager toolbar, click Insert.

The Insert MLT dialog box opens (Figure 48).
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Figure 48   Insert MLT dialog box — pair of devices selected

3 In the Id field for both nodes, select the same Id number for the MLT.

4 In one of the Name fields, type the name of the MLT. 

The text you type appears in both Node Name fields.

5 In the Ports text box, select the ports to be added to the MLT.

In the Insert MLT dialog box, port numbers are highlighted in green to 
indicate that the ports are already connected between the two devices. 
Dimmed port numbers mean that those ports are inactive and cannot be 
included in the MLT.

6 Select the MLT type option.

The default is Access.

7 Select the VLAN IDs for both nodes to be included in the MLT port.

8 Click Ok.

Table 35 describes the items in the Insert MLT dialog box for a pair of 
devices.

Note: Both nodes must belong to the same VLAN ID list.
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Viewing MLT port information

To view port information as you configure an MLT:

The Port dialog box opens (Figure 49).

Table 35   Insert MLT dialog box items for two nodes

Section Item Description

Node 1 Node IP address of the first network device to be configured 
on an MLT.

Id Unique identifier for the MLT that is automatically 
assigned by MultiLink Trunking Manager.

Name User-defined name of the MLT. (When you type the 
name for one node, the name is automatically added to 
the other node.)

Ports Ports enabled on the MLT.

Type One of the following types of MLT:
• Access

• Trunk
The default is Access.

VlanIds VLAN IDs found on the device. 

Node 2 Node IP address of the second network device configured on 
the MLT.

Id Unique identifier for the MLT that is automatically 
assigned by MultiLink Trunking Manager.

Name User-defined name of the MLT. (When you type the 
name for one node, the name is automatically added to 
the other node.)

Ports Ports enabled on the MLT.

Type One of the following types of MLT:
• Access
• Trunk

The default is Access.

VlanIds VLAN IDs found on the device.

In the Insert MLT dialog box, point to a port number.
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To open the Insert MLT dialog box, refer to “Creating an MLT with one 
device” on page 111.

Figure 49   Port dialog box

The information displayed in the dialog box includes the VLAN(s) and STG(s) to 
which the port belongs and the port link status. The port link status information 
includes whether the port is up or down and what other device/ports the port is 
connected to.

Editing a port on an MLT

To edit a port on an existing MLT:

1 In the navigation pane, select an MLT.

The MLT table opens in the contents pane.

2 In the table, double-click the PortMembers field.

The PortMembers dialog box opens (Figure 50).

Figure 50   PortMembers dialog box

3 Click the port numbers that you want to add or delete from the MLT.

Port numbers that appear to be pressed in are already being used, and port 
numbers that are dimmed are inactive and cannot be used.

4 Click Ok.
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Deleting an MLT

To delete an MLT:

1 In the navigation pane, select a device and do one of the following:

• From the MultiLink Trunking Manager menu bar, choose Edit > Delete.

• On the MultiLink Trunking Manager toolbar, click Delete.

The Delete dialog box opens, asking you to confirm the deletion (Figure 51).

Figure 51   Delete dialog box

2 Click Yes.

Editing an MLT

To edit an MLT:

1 In the navigation pane, select a device.

The MLT table opens in the contents pane.

2 Double-click the field in the table.

3 Type information in the text boxes, or select from a list.

4 On the MultiLink Trunking Manager toolbar, click Apply Changes.

Your changes are displayed in bold.
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Highlighting devices and MLT links in Optivity Switch 
Manager

Optivity Switch Manager displays the topology information from MultiLink 
Trunking Manager in the contents pane.

To highlight devices and their MLT in Optivity Switch Manager:

1 In the navigation pane, select a device with a trunk (MLT) connection.

The Trunk table opens in the MultiLink Trunking Manager contents pane 
(Figure 52).

Figure 52   Trunk table

2 From the MultiLink Trunking Manager menu bar, choose View > Highlight 
Topology.

3 Return to the Optivity Switch Manager window.

The topology view opens in the Optivity Switch Manager contents pane with 
devices connected to the MLT highlighted in blue and the ports in the MLT 
highlighted in green (Figure 53).

If you select either a no trunk or an isolated device from the MultiLink 
Trunking Manager navigation pane, only the highlighted device appears in the 
Optivity Switch Manager contents pane.
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Figure 53   Highlight topology view in Optivity Switch Manager
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Chapter 6
Using Multicast Manager

This chapter describes Multicast Manager, which you can use to monitor multicast 
protocols deployed across the devices discovered by Optivity Switch Manager.

The chapter includes information about the following topics:

• What is Multicast Manager? (next)

• Starting Multicast Manager (page 123)

• Multicast Manager window (page 123)

• Using Multicast Manager (page 130)

• Viewing Multicast Manager information in Optivity Switch Manager 
(page 160)

What is Multicast Manager?

Multicast Manager allows you to view devices within a network that are 
participating in multicast groups and using multicast protocols, including group 
addresses, source subnets, forwarding paths, and last reporters in the group. 
Multicast Manager also allows you to view devices using a specific multicast 
protocols, the forwarding path to either all destination devices or a selected 
intermediate device.

Note: To configure multicast groups, you must use Device Manager.
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Multicast protocols

Passport 1000 Series switches and Passport 8600 switches support the following 
multicast protocols:

• Distance Vector Multicast Routing Protocol (DVMRP)

• Internet Group Management Protocol (IGMP)

• IGMP Snooping

At its most basic, IP multicast is the communication of data and services to 
multiple destinations with a single transmission. Refer to Networking Concepts 
for the Passport 1000 Series Routing Switch Release 2.0 and Networking 
Concepts for the Passport 8000 Series Routing Switch for more information on 
multicast and multicast protocols.

DVMRP

DVMRP advertises shortest-path routes to multicasting source networks (any 
network containing hosts with the capability to issue multicast datagrams). When 
DVMRP is coupled with IGMP membership, a multicast stream is learned from 
both the routers and directly attached hosts.

IGMP

IGMP allows a host to register group memberships with the local querier router to 
receive any datagrams sent to this router and targeted to a group with a specific IP 
Multicast address. The protocol also allows a router to learn the existence of 
group members on its directly attached networks. The router periodically sends a 
general query message to each of its local networks. Any host that is a member of 
any multicasting group identifies itself by a sending a response.

IGMP Snooping

IGMP Snooping uses IGMP messages to prune group membership per port within 
a VLAN. The switch listens to group reports for each port and builds a database of 
multicast group members per port. Only those ports that are specified in the 
database receive multicast traffic, instead of all the ports in the VLAN.
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Multicast Manager features

Multicast Manager supports devices that implement rcVlanIgmpSnoop and/or 
igmp, rcIpDvmrp, dvmrp, and ipMRoute MIB groups.

Multicast Manager allows you to:

• Display information on the multicast protocols configured and enabled on the 
devices discovered by Optivity Switch Manager.

• Highlight all devices in the topology network map if the multicast protocol is 
selected from the Multicast Manager navigation tree.

• Provide information about multicast groups with active members, including 
information on group address, source subnet, and last reporters.

• Display the multicast forwarding path for a selected source/group to all 
destination devices or to a selected intermediate device.

Starting Multicast Manager

To start Multicast Manager:

• From the Optivity Switch Manager menu bar, choose Tools > Multicast 
Manager.

• On the keyboard, press [F4].

• On the Optivity Switch Manager toolbar, click Multicast Manager.

The Multicast Manager window opens (Figure 54).

Multicast Manager window

The Multicast Manager window contains the parts identified in Figure 54.

Do one of the following:
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Figure 54   Multicast Manager window

Table 36 describes the parts of the Multicast Manager window.

Table 36   Multicast Manager window parts

Part Description

Title bar Displays the submanager name.

Menu bar Provides access to all Multicast Manager commands.

Toolbar Provides quick access to commonly-used Multicast Manager 
commands. 

Navigation pane Provides a navigation tree showing Multicast Manager protocols 
and groups.

Contents pane Displays information selected in the navigation pane.

Scroll bar Provides access to an entire table, folder at the bottom of the 
navigation tree, or other text that spans an area larger than the 
window.

Status bar Displays status information, including the command description 
from a tool tip, and a key to the type of Multicast groups 
discovered.

Toolbar

Contents

Scroll bar

Title bar
Menu bar

Navigation

Status bar

pane

pane
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Menu bar

The menu bar provides menus for operating the Multicast Manager. Table 37 
describes the Multicast Manager menus and commands.

Table 37   Multicast Manager menus and commands

Menu Command Shortcut key Purpose

File Reload [Ctrl]+R Reloads the Multicast Manager 
information.

Save 
Diagnostic 
Information

[Ctrl]+D Saves the diagnostic information about 
the multicast configurations and groups.

Print [Ctrl]+P Opens the Print dialog box, where you 
set parameters to print.

Close Closes Multicast Manager.

Edit Undo 
Changes

[Ctrl]+Z Reverses any changes you made to a 
record.

Copy [Ctrl]+C Copies the contents of the selected cell.

Paste [Ctrl]+V Pastes the cell contents when you 
select a new location.

Insert [Ctrl]+I Opens the Insert dialog box.

Delete [Ctrl]+D Removes a selection and displays a 
message box to confirm deletion.

Apply 
Changes

[Ctrl]+A Applies changes made to your multicast 
configuration to the device configuration 
file.

Find [Ctrl]+F Opens the Find dialog box, where you 
set parameters to find matching entries 
in your network.

Note: In read only mode, except for the Find command, Edit options are 
unavailable (greyed-out).
Using Optivity Switch Manager, Release 1.1.0.0



126 Chapter 6 Using Multicast Manager

  
Toolbar

The toolbar includes the same buttons as Optivity Switch Manager and the other 
submanagers. For information about the toolbar buttons available in Multicast 
Manager, refer to Table 5 on page 36.

Navigation pane

The Multicast Manager navigation pane (Figure 55) is on the left side of the 
window. It contains the protocol and group folders in the navigation tree. The first 
four branches of the navigation tree list the multicast protocols supported by the 
devices. The last branch lists the root of all active multicast groups, with the first 
level identifying the source subnets and the second level identifying the 
intermediate forwarding nodes.

In the navigation pane, you can select the folder for which you want to view 
multicast information, or use the Print command to print the navigation tree.

View Highlight 
Topology

Highlights the devices running the 
multicast protocol within the topology 
map in the Optivity Switch Manager 
contents pane, and highlights the 
multicast forwarding path from the 
source subnet. 
To view source subnets or forwarding 
devices, you must select the IP address 
associated with the subnet or device.

Audit Queries the network topology to report 
any discrepancies.

Help Online 
Support

Opens a Web browser and loads the 
Nortel Networks Customer Support Web 
page.

About 
Multicast 
Manager

Displays information about Multicast 
Manager.

Table 37   Multicast Manager menus and commands (continued)

Menu Command Shortcut key Purpose
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Figure 55   Multicast Manager navigation pane

Contents pane

When you select a network resource in the navigation pane, a table opens in the 
contents pane (Figure 56).

Note: In this release, tables are not available for multicast source subnet 
nodes and intermediate forwarding nodes from the navigation pane.
Using Optivity Switch Manager, Release 1.1.0.0
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Figure 56   DVMRP Table in the contents pane

To view the multicast information in the contents pane:

The DVMRP table opens in the contents pane. The example in Figure 56 
shows the DVMRP information found on device 10.10.40.31.

Status bar

The Multicast Manager status bar is located at the bottom of the Multicast 
Manager window and contains two fields.

Table 38 describes the fields in the Multicast Manager status bar.

In the navigation pane, select a device icon from the list under the protocol.
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Finding a network resource

To find a network resource:

1 Click any device in the navigation pane, or in the table view, and do one of the 
following:

• From the Multicast Manager menu bar, choose Edit > Find.

• On the Multicast Manager toolbar, click Find.

The Find dialog box opens (Figure 57).

Figure 57   Find dialog box

2 In the Find text box, type the text or number for your search.

3 In the In section, click the Tree option to search the navigation pane, or click 
the Table option to search the contents pane.

4 Click Next.

Multicast Manager starts its search and highlights the first match it finds or 
displays a message that it found no matches.

Table 38   Multicast Manager status bar fields

Field Description

Message Located on the left, the message field displays status information about 
operation results.

Icon Located on the right, the icon field provides a legend for the type of end 
station receiving the multicast traffic. The icons represent:

• A multicast group
• A multicast source subnet
• A multicast forwarding node
Using Optivity Switch Manager, Release 1.1.0.0
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5 If a first match was found, click Next to find each subsequent match, or click 
Previous to go back to your last match.

Using Multicast Manager

Multicast Manager displays the following multicast protocols and groups 
supported on the devices discovered in the network topology:

• Layer 2 IGMP Snoop

• Layer 3 IGMP

• DVMRP

• Multicast routes

The last group displayed is the Multicast Groups. Multicast groups are defined by 
a multicast address and are listed in Multicast Manager by their multicast address.

To open a new table, double-click the multicast address listed below the protocol.

Viewing IGMP Snoop groups

IGMP Snooping works at layer 2 in the network. You configure IGMP Snooping 
using Device Manager. All devices supported by Optivity Switch Manager can be 
configured for IGMP Snooping.

To view the information associated with IGMP Snoop groups: 

The IGMP Snoop Table opens with the General tab displayed (Figure 58).

Select a device listed under the IGMP Snoop folder.

Note: If a BayStack switch or a Business Policy Switch 2000 is selected, 
only the General tab is displayed.
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Figure 58   IGMP Snoop Table

The IGMP Snoop Table contains five tabs that display information about IGMP 
snooping:

• General tab (next)

• Receiver tab (page 133)

• Sender tab (page 135)

• Static tab (page 137)

• Access tab (page 138)

General tab

The General tab (Figure 59) displays the settings for IGMP Snoop on the selected 
device.
Using Optivity Switch Manager, Release 1.1.0.0
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Figure 59   General tab

Table 39 describes the fields in the General tab.

Table 39   General tab fields

Field Description

VlanId VLAN ID of the VLAN.

Enable Indicates whether IGMP snooping works only when a 
multicast router exists in the VLAN.

ReportProxyEnable Whether or not the IGMP report proxy feature is enabled. 
When this feature is enabled, reports are forwarded from 
hosts to the multicast router once per group per query 
interval or when there is new group information. When 
this feature is disabled, all reports from different hosts are 
forwarded to multicast routers, and more than one group 
report may be forwarded for the same multicast group per 
query interval. The default is enabled.
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Receiver tab

The Receiver tab (Figure 60) provides information about IGMP group receivers.

Robustness Robust value (based on the network’s tendency to lose 
data). This value, along with the query interval, is used to 
determine the group membership timeouts. It should be 
set to that of the multicast router in the network. If more 
than one multicast router is within a VLAN and the robust 
values are different, set the Passport switch to the highest 
value. The range is 2 to 255. The default is 2.

QueryInterval(sec) In general, the time between queries sent to the host. this 
value is used to determine the multicast group 
membership timeouts. The real interval between queries 
is still dependent on the multicast router within the VLAN.

Set this value to be the same as that of the multicast 
routers in the VLAN. If there are multiple multicast routers 
on the net, select the highest query interval value. The 
query interval is in seconds (1 to 65535) with a default of 
125 seconds.

MRouterPorts Ports that have been configured as Multicast Router 
Ports. Such ports provide connectivity but do not have to 
be directly attached to a multicast router so the multicast 
data and group reports are forwarded to the router. 

ActiveMRouter Active Multicast Router Ports are ports that provide 
connectivity but do not have to be directly attached to a 
multicast router. These ports include the Querier port and 
all ports in the forwarding state that were configured by 
the user, as well as those that were dynamically learned 
using receiving queries. 

ActiveQuerier IP address of the last querier (multicast router) of this 
VLAN that was heard by the switch.

QuerierPort Port on which the LastQuerier is being heard.

MRouterExpiration Time remaining before the multicast router is aged out. If 
the switch does not receive any queries before this time 
expires, it flushes out all group memberships known to the 
VLAN. The Query Max Response Interval (obtained from 
the Queries received) is used as the timer resolution.

Table 39   General tab fields (continued)

Field Description
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Figure 60   Receiver tab

Table 40 describes the fields in the Receiver tab.

Table 40   Receiver tab fields

Field Description

VlanId VLAN ID of the VLAN.

GrpAddress Address of the multicast group to which the receiver 
subscribes.

InPort Port where group membership was learned. If there are 
multiple members attached using the same port, only the 
last group reported is shown for the port.

Member Source IP address of the member who joined.
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Sender tab

The Sender tab (Figure 61) displays information about the IGMP Snoop sender 
device.

Expiration Time left until this member is aged out. This value is 
derived from the Robust Value, MaxResponse Time value, 
and Query Interval. The Query Max Response Interval 
(obtained from the Queries received) is used as the timer 
resolution. Increasing the Robust Value also increases the 
expiration value.

Type Static or dynamic:
• Static membership is configured by the user using the 

Multicast Static window.
• Dynamic membership is what the switch learned from 

receiving group reports.

An entry can change from static to dynamic if the switch 
learns of a membership dynamically through a static port. 
In this case, the entry is not deleted when the expiration 
value goes to zero; instead, its type goes back to “static.”

Table 40   Receiver tab fields (continued)

Field Description
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Figure 61   Sender tab

Table 41 describes the fields in the Sender tab.

Table 41   Sender tab fields

Field Description

VlanId VLAN ID of the ingress VLAN.

GrpAddress Address of the multicast group that the sender is 
broadcasting.

InPort Port where group membership was learned. If the source 
(sender) moves to another switch port, this field is not 
automatically updated.

Member Source IP address of the member who joined.

Action Last action you performed (flush group, flush entry, or 
none). 
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Static tab

The Static tab (Figure 62) displays information about the static entries created to 
forward IGMP Snoop data for a given multicast group.

Figure 62   Static tab

Table 42 describes the fields in the Static tab.

Table 42   Static tab fields

Field Description

VlanId VLAN ID of the VLAN.

GrpAddress Multicast group address of the multicast stream.
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Access tab

The Access tab (Figure 63) displays information about the multicast groups or 
range of multicast address that were either denied transmission, denied reception, 
or denied both transmission and reception of multicast traffic.

Figure 63   Access tab

Table 43 describes the fields in the Access tab.

MemberPort Ports which redirect the multicast stream for this multicast 
group. The ports are member ports of the VLAN.

NotAllowedToJoin Ports that do not receive the multicast stream for this 
multicast group.

Table 42   Static tab fields (continued)

Field Description
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Viewing L3-IGMP information 

Layer 3 IGMP allows an IP Multicast router to learn the existence of host group 
members on their directly connected subnets.

Passport 1000 Series switches and Passport 8600 switches support layer 3 IGMP.

To view L3-IGMP information:

The L3 IGMP table opens in the contents pane with the Cache tab displayed 
(Figure 64).

Table 43   Access tab fields

Field Description 

VlanId VLAN ID for the VLAN.

GrpAddress Multicast group address of the multicast stream.

HostAddress IP address of the host whose membership is to be 
controlled.

HostMask Subnet mask of the host whose membership is to be 
controlled. 

Mode The host address mode, which can be one of the 
following:
• denyTx—deny transmit mode
• denyRx—deny receive mode

• denyBoth—deny transmit and receive mode

Select a device listed under the L3 IGMP icon.
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Figure 64   IGMP Table

The IGMP Table contains three tabs that display information about IGMP:

• Cache tab (next)

• Interface tab (page 142)

• Group tab (page 144)

Cache tab

The Cache tab (Figure 65) displays L3-IGMP cache information.
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Figure 65   Cache tab

Table 44 describes the fields in the Cache tab.

Table 44   Cache tab fields

Field Description

Address IP multicast group address for which this entry contains 
information.

Interface Interface from which the corresponding multicast group 
address is heard.

LastReporter IP address of the source of the last membership report 
received for this IP multicast group address on this 
interface. If no membership report has been received, the 
object has the value 0.0.0.0.
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Interface tab

The Interface tab (Figure 66) displays statistics about the L3-IGMP interfaces 
used.

Figure 66   Interface tab (L3-IGMP partial view)

Table 45 describes the fields in the Interface tab. 

ExpiryTime Amount of time (in seconds) remaining before this entry is 
aged out.

Version1HostTimer(sec) Time remaining (in seconds) until the local router assumes 
that there are no longer any IGMPv1 members on the IP 
subnet attached to this router. Upon hearing an IGMPv1 
Membership Report, this value is reset to the group 
membership timer. While this value is not zero, the router 
ignores any IGMPv2 Leave messages it receives for this 
group.

Table 44   Cache tab fields (continued)

Field Description
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Table 45   Interface tab fields

Field Description

Interface Interface on which IGMP is enabled.

QueryInterval(sec) Frequency (in seconds) at which IGMP host query packets 
are transmitted on the interface. The range is from 1 to 
65535. The default is 125.

Status IGMP row status. When an interface has been assigned an 
IP address and DVMRP is enabled, status is shown as 
active. Otherwise, it is shown as notInService. 

Version Version of IGMP that is configured on the interface. For 
IGMP to function correctly, all routers on a LAN must be 
configured to run the same version of IGMP on that LAN.

Querier Address of the IGMP querier on the IP subnet to which the 
interface is attached.

QueryMax
ResponseTime(sec)

Maximum response time (in seconds) advertised in 
IGMPv2 general queries on this interface. Smaller values 
allow a router to prune groups faster. This value for 
IGMPv1 is not configurable and has a default value of 10 
seconds.

WrongVersion
Queries

Number of queries received with an IGMP version that 
does not match the interface. IGMP requires that all routers 
on a LAN be configured to run the same version of IGMP. If 
any queries are received with the wrong version, it 
indicates a version mismatch.

Joins Number of times a group membership has been added on 
this interface; that is, the number of times an entry for this 
interface has been added to the cache table. This number 
gives an indication of the amount of IGMP activity over 
time.

Robustness This value is equal to the number of expected query packet 
losses per serial query interval, plus 1. If a network is 
expected to lose query packets, increase the robustness 
value. The range is from 2 to 255 with a default value of 2. 
The default value of 2 means that one query per query 
interval may be dropped without the querier aging out.

LastMemQueryIntval Maximum response time inserted into group-specific 
queries sent in response to leave group messages; also 
the time between group-specific query messages. 
Increasing this parameter increases the time before aging 
hosts on the network. It also increases the number of 
retransmits of group-specific queries. The range is from 1 
to 255. The default value is 1.
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Group tab

The Group tab (Figure 67) displays L3-IGMP multicast group information.

Figure 67   Group tab

Table 46 describes the fields in the Group tab.

Table 46   Group tab fields

Field Description

IpAddress IP address (Class D), designated as the multicast group 
address, that members can join. A group address can be 
the same for many incoming ports.

Members IP address of a member that has issued a group report for 
this group.
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Viewing DVMRP information

DVMRP routers listen to all IGMP host membership reports, even if they are not 
the designated querier, and keep a local database of every host membership 
reporter.

Passport 1000 Series switches and Passport 8600 switches support DVMRP.

To view DVMRP information:

The DVMRP table opens with the Globals tab displayed in the contents pane 
(Figure 68).

InPort A unique value to identify a brouter interface or a logical 
interface (VLAN) that has received Group reports from 
various members.

Expiration Time left before the group report expires on this port. This 
variable is updated when a group report is received.

Select a device listed under the DVMRP folder.

Table 46   Group tab fields (continued)

Field Description
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Figure 68   DVMRP Table

The DVMRP Table contains five tabs that display DVMRP information:

• Globals tab (next)

• Interface tab (page 148)

• Neighbor tab (page 150)

• Route tab (page 151)

• Next Hop tab (page 153)

Globals tab

The Globals tab (Figure 69) displays the global DVMRP settings for the network.
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Figure 69   Globals tab

Table 47 describes the fields in the Globals tab.

Table 47   Globals tab fields  

Field Description

Enable Whether DVMRP is enabled (true) or disabled (false) on 
the switch.

UpdateInterval Periodically each multicast router advertises routing 
information on each DVMRP interface, using the DVMRP 
export message. This field shows the time interval (in 
seconds) between DMVRP updates. The range is from 10 
to 2000 with a default of 60. In DVMRPv3, this variable is 
also known as the Route Report Interval.
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Interface tab

The DVMRP Interface tab (Figure 70) displays information about the interfaces 
with DVMRP enabled.

TriggeredUpdate
Interval

Triggered updates are sent when routing information 
changes. This value is the amount of time (in seconds) 
between triggered update messages. The range is from 5 
to 1000 with a default value of 5. In DVMRPv3, this 
variable is also known as the Minimum Flash Update 
Interval.

LeafTimeOut When DVMRP advertises a route on an interface, it waits a 
period of time for a DVMRP neighbor to respond positively. 
If no neighbor responds in the given time, the router 
considers the network attached to the interface to be a leaf 
network. The leaf timer shows you how long (in seconds) 
the router waits for a response from a neighbor. The range 
is from 25 to 4000 with a default value of 200.

NbrTimeOut The neighbor report timer specifies how long (in seconds) 
the router waits to receive a report from a neighbor before 
considering the connection inactive. The range is from 35 
to 8000 with a default of 140.

NbrProbeInterval How often the DVMRP router sends probe messages on its 
interfaces. The range is 5 to 30 seconds with a default 
of 10.

VersionString The router’s DVMRP version information.

GenerationId Used by neighboring routers to detect whether a reset or 
disable/enable DVMRP action has occurred to the switch 
or to a particular interface. If so, the router resends the 
entire multicast routing table to its neighbor immediately, 
instead of waiting for the next scheduled update. 

NumRoutes Number of entries in the routing table. You can use this 
information to monitor the routing table size to detect illegal 
advertisements of multicast routes.

ReachableRoutes Number of entries in the routing table with noninfinite 
metrics. You can use this number to detect network 
partitions by observing the ratio of reachable routes to total 
routes.

Table 47   Globals tab fields (continued) 

Field Description
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Figure 70   Interface tab (DVMRP) fields

Table 48 describes the fields in the Interface tab.

Table 48   Interface tab—DVMRP fields

Field Description

Interface The DVMRP interface, slot/port number or VLAN 
identification.

OperState Current operational state of this DVMRP interface (up or 
down).

LocalAddress IP address of the DVMRP router interface. 

Metric The distance metric for this interface, used to calculate 
distance vectors. The range is 1 to 31. The default value is 
1, which means local delivery only.
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Neighbor tab

The Neighbor tab (Figure 71) displays the DVMRP neighbors, which are the 
multicast routers that have an interface on the same network.

Figure 71   Neighbor tab

Table 49 describes the fields in the Neighbor tab.

Table 49   Neighbor tab fields

Field Description

Interface The DVMRP slot/port number or the virtual interface 
(VLAN) used to reach this DVMRP neighbor.

Address IP address of the DVMRP neighbor for which this entry 
contains information.

ExpiryTime Time remaining before this DVMRP neighbor is aged out.

GenerationId Neighboring router’s generation ID number.
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Route tab

The DVMRP Route tab (Figure 72) shows the table of routes learned through 
DVMRP route exchange.

MajorVersion Neighboring router’s major DVMRP version number.

MinorVersion Neighboring router’s minor DVMRP version number.

Capabilities Neighboring router’s capabilities. The probe flag is 1 byte 
long with the lower 4 bits containing the following 
information:

• The leaf bit (0) indicates that the neighbor has only one 
interface with neighbors.

• The prune bit (1) indicates that the neighbor supports 
pruning. 

• The generationID bit (2) indicates that the neighbor 
sends its generation ID in probe messages. 

• The mtrace bit (3) indicates that the neighbor can 
handle mtrace requests.

State State of neighbor adjacency: 

• oneway—The switch sees a packet from the neighbor 
but no adjacency has been established.

• active—Adjacency exists in both directions.

• ignoring—The switch ignores neighbor packets.
• down—The interface is not enabled.

Table 49   Neighbor tab fields (continued)

Field Description
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Figure 72   Route tab (DVMRP)

Table 50 describes the fields in the Route tab.

Table 50   Route tab (DVMRP) fields

Field Description

Source The network address that, when combined with the 
corresponding route SourceMask value, identifies the 
sources for which this entry contains multicast routing 
information.

SourceMask The network mask that, when combined with the 
corresponding route Source value, identifies the sources 
for which this entry contains multicast routing information.

UpstreamNeighbor Address of the upstream neighbor (in other words, the RPF 
neighbor) from which IP datagrams from these sources are 
received, or 0.0.0.0 if the network is local.
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Next Hop tab

The Next Hop tab (Figure 73) displays the next hop on outgoing interfaces for 
routing IP multicast datagrams.

Figure 73   Next Hop tab

Table 51 describes the fields in the Next Hop tab.

Interface DVMRP interface slot/port number or VLAN ID on which IP 
datagrams sent by these sources are received.

Metric Distance in hops to the source subnet. Range is 1 to 32. 

ExpiryTime Amount of time (in seconds) remaining before this entry is 
aged out.

Table 50   Route tab (DVMRP) fields (continued)

Field Description
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Viewing MRoute information

Multicast Route (MRoute) information contains the details about the multicast 
routes found in the network. 

To view Multicast Route information: 

The MRoute table opens with one tab, the Route tab, displayed.

Route tab

The Route tab (Figure 74) lists multicast route information.

Table 51   Next Hop tab fields

Field Description

Source The network address that, when combined with the 
corresponding next hop SourceMask value, identifies the 
source for which this entry specifies a next hop on an 
outgoing interface.

SourceMask The network mask that, when combined with the 
corresponding next hop Source value, identifies the source 
for which this entry specifies a next hop on an outgoing 
interface.

OutInterface DVMRP interface slot/port number or VLAN ID for the 
outgoing interface for this next hop.

Type The type is:
• leaf if no downstream dependent neighbors exist on the 

outgoing virtual interface

• branch if downstream dependent neighbors do exist on 
the outgoing virtual interface.

Select a device listed under the MRoute folder.
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Figure 74   Route tab (MRoute)

Table 52 describes the fields in the Route tab.

Table 52   Route tab (MRoute) fields

Field Description

GroupAddress IP multicast group address for which this entry contains 
multicast routing information.

SourceAddress Network address that, when combined with the 
corresponding route SourceMask value, identifies the 
sources for which this entry contains multicast routing 
information.

SourceMask Network mask that, when combined with the corresponding 
route Source value, identifies the sources for which this 
entry contains multicast routing information.

UpstreamNeighbor Address of the upstream neighbor (in other words, the RPF 
neighbor) from which IP datagrams from these sources to 
this multicast address are received or 0.0.0.0 if the network 
is local.
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Viewing Multicast Groups information

Multicast Group information contains details about multicast groups with active 
members, including their multicast group address, source subnet, and last reporter.

To view Multicast Group information:

The Multicast Group table opens with the Source Subnets tab displayed in the 
contents pane (Figure 75).

Interface DVMRP interface slot/port number or VLAN ID on which IP 
datagrams sent by these sources to this multicast address 
are received.

ExpiryTime Amount of time remaining before this entry is aged out. The 
value 0 indicates that the entry is not subject to aging.

Protocol Routing protocol through which this route was learned. 
Currently only DVMRP is supported.

Select a multicast address listed under the Multicast Groups icon.

Table 52   Route tab (MRoute) fields (continued)

Field Description
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Figure 75   Multicast Group table

The Multicast Group table contains two tabs that display multicast information:

• Source Subnets tab (next)

• Receivers tab (page 159)

Source Subnets tab

Multicast traffic must travel through source subnets to reach either forwarding 
devices or multicast receivers.

The Source Subnets tab (Figure 76) displays the source subnet address and subnet 
mask of the multicast group address.
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Figure 76   Source Subnets tab

Table 53 describes the fields in the Source Subnets tab.

Table 53   Source Subnets tab fields

Field Description

SubnetAddress Network address that, when combined with the 
corresponding SubnetMask value, identifies the source 
multicast address.

SubnetMask Network mask that, when combined with the corresponding 
SubnetAddress value, identifies the source multicast 
address.
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Receivers tab

The Receivers tab (Figure 77) displays the addresses of the last reporters for the 
active multicast group.

Figure 77   Receivers tab (Multicast Groups)

Table 54 describes the fields in the Receivers tab.
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Viewing Multicast Manager information in Optivity 
Switch Manager

While the Multicast Manager window is open, you can highlight the following 
information on the topology map in the Optivity Switch Manager main window:

• Location of a particular multicast devices

• Multicast forwarding path from a source subnet to a multicast node

• Devices actively using a selected multicast protocol

Highlighting a multicast device

To highlight a multicast device:

1 In the Multicast Manager navigation pane, do one of the following:

• Select a protocol icon.

• Select a single device.

Devices supported by the protocol are highlighted.

2 From Multicast Manager menu bar, choose View > Highlight Topology.

The Highlight Topology option remains selected until you deselect it. 
However, if you select a multicast group in the navigation pane, this option is 
not available.

Table 54   Receivers tab (Multicast Groups) fields

Field Description

LastReporter IP address of the source of the last membership report 
received for this IP multicast group address on this 
interface. If no membership report has been received, the 
object has the value 0.0.0.0.

Querier Address of the IGMP querier on the IP subnet to which the 
interface is enabled. The address in parentheses is the 
forwarding node.
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3 Return to the Optivity Switch Manager window.

— If a protocol icon was selected, all devices supported by the protocol are 
highlighted.

— If a single device was selected, the device is highlighted.

Highlighting a multicast forwarding path

To highlight a multicast forwarding path from a source subnet to a multicast node 
within a multicast group:

1 In the Multicast Manager navigation pane, select a forwarding node under a 
multicast group and source subnet that you want to view, or select a source 
subnet under a multicast group.

2 From Multicast Manager menu bar, choose View > Highlight Topology.

3 Return to the Optivity Switch Manager window.

— If a forwarding node was selected, the devices and a single forwarding 
path are highlighted (Figure 78). 

— If a source subnet folder was selected, the devices and all forwarding 
paths coming out of a source are highlighted.
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Figure 78   Optivity Switch Manager with forwarding node highlighted

You can also select a multicast protocol in Multicast Manager and view in 
Optivity Switch Manager the devices that are actively using that protocol.

To view devices using multicast protocols:

1 In the Multicast Manager navigation pane, select a multicast protocol from the 
first four branches in the tree.

2 Return to the Optivity Switch Manager window.

The devices using DVMRP are highlighted (Figure 79).
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Figure 79   Optivity Switch Manager window with devices using DVMRP 
highlighted
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Chapter 7
Using Log Manager

Log Manager allows you to open log files that are transferred from a network 
device. The log file is a file saved on the flash memory of a device. You can use 
the log file content (displayed in ASCII format) to analyze any activity written to 
the log file that may be of potential concern.

This chapter includes information about the following topics:

• Uploading Passport syslog files to your management station (next)

• Starting Log Manager (page 170)

• Opening a syslog file (page 171)

• Exporting a log file (page 174)

• Locating specific log entries (page 174)

• Filtering log entries (page 176)

Note: Log files and Optivity Switch Manager must reside on the same 
management station.
Using Optivity Switch Manager, Release 1.1.0.0
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Uploading Passport syslog files to your management 
station

This section describes how to upload Passport 8000 Series (version 3.0 and 
higher) syslog files to your management station. The procedure here illustrates the 
general principles of the upload process for all switches. For specific details of 
using Device Manager or the CLI on other switches, refer to the Device Manager 
and CLI reference guides for those switches.

You can upload Passport 8000 Series syslog files to your management station 
using the FileSystem dialog box in Device Manager or using the command line 
interface (CLI). For more information about using Device manager or the CLI, 
refer to the reference guides for Device Manager and the CLI listed in “Related 
publications” on page 18.

Uploading a file using Device Manager

To upload a Passport 8000 Series syslog file using Device Manager:

1 From the Device Manager menu bar, choose Edit > File System.

The FileSystem dialog box opens with the Copy File tab displayed 
(Figure 80).

Note: To upload syslog files, you must have a TFTP server installed on 
the management station.

Note: The Passport 1000 Series does not support this feature.
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Figure 80   Copy File tab

2 Enter the source address of the syslog file.

3 Enter the destination address of the syslog file.

4 Select the start radio button.

5 Click Apply.

Uploading a file using the CLI

If remote access to the CLI is enabled for a switch, you can access the CLI 
remotely to upload files. This section describes how to use Telnet to access the 
CLI and copy a file to your management station.

You can initiate a Telnet session from Device Manager or you can use Telnet 
software installed on your management station. After the Telnet session is active, 
you log on to the switch and use the copy command to upload the file.

Initiating a Telnet session from Device Manager

To initiate a Telnet session from Device Manager:

1 On the Device Manager toolbar, click the Telnet icon.

The Telnet dialog box opens showing the CLI login prompt for the selected 
switch (Figure 81).
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Figure 81   Telnet dialog box

2 To begin your Telnet session, enter your login name and password, for 
example:

Login: rwa

Password: *** (rwa)

Using the Telnet application

To initiate a Telnet session using the Telnet application:

1 Launch your Telnet application.

2 From the menu bar, click Connect.

3 Do one of the following:

• Select an IP address from the displayed list.

• Choose Remote System and enter an IP address.

The Telnet window displays the CLI login prompt for the selected switch 
(Figure 82).
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Figure 82   Telnet window

4 To begin the Telnet session, enter your login name and password, for 
example:

Login: rwa

Password: *** (rwa)

When you have accessed the CLI, you use the copy command to upload the file. 

Uploading the syslog file

To use the copy command to upload a file:

copy <srcfile> <destfile>

where:

srcfile is the file name or number of the source file in flash, pcmcia, 
config, nvram, tftp, or trace.

destfile is the file name and path, including the IP address of the 
management station.

For example, the following command copies a syslog file to the management 
station located at IP address 10.170.137.105:

copy /pcmcia/syslog.txt 10.170.137.105:syslog.txt

Enter:

************************************
* Nortel Networks, Inc.            *
* Copyright (c) 1996-2000          *
* All Rights Reserved              *
* Passport 8010                    *
* Software Release _B047           *
************************************

Login:
Using Optivity Switch Manager, Release 1.1.0.0
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Passport/Accelar 1000 Series switches (version 2.x)

To upload a Passport/Accelar 1000 Series syslog file to your management station, 
use the CLI copy command as described in the CLI reference guide that was 
shipped with the switch.

For example, the following CLI command and prompt sequence copies a syslog 
file to the management station located at IP address 10.170.137.10: 

Passport-1200# copy f t

Enter destination tftp server address [10.170.137.105]:

Enter destination file [syslog]: syslog

tftp starting ... Press any key to abort the operation.

tftp result: success

Starting Log Manager

To start Log Manager:

• From the Optivity Switch Manager menu bar, choose Actions > Log 
Manager.

• On the Optivity Switch Manager toolbar, click Log Manager.

The SysLog dialog box opens (Figure 83). Until you open a syslog file, the 
dialog box does not contain any log file information.

Do one of the following:
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Figure 83   SysLog dialog box

Opening a syslog file

To open a syslog file:

1 In the SysLog dialog box, click the folder icon.

The Open sysLog dialog box opens (Figure 84).

Figure 84   Open sysLog dialog box
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2 In the File name text box, type the name of the log file to import, or use the 
Browse button to locate the log file.

3 Click Open.

The log file is imported into the SysLog dialog box (Figure 85). 

Figure 85   Imported log file in SysLog dialog box

The SysLog dialog box includes some buttons that are the same as those available 
on the toolbar of Optivity Switch Manager and the other submanagers. For 
information about these common buttons, refer to Table 5 on page 36. 

Table 55 describes the items and buttons that are specific to the SysLog dialog 
box.

Table 55   SysLog dialog box items and buttons

Item or button Description

Id The number assigned to the log entry.

Timestamp The time the entry entered the log.
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Severity The severity level of the log entry. The possible severity 
levels are:

• Info—Informational message only
• Warning—There may be a misconfiguration in the 

network, but you do not need to take action.

• Error—There is a misconfiguration that you must 
correct for the device to work correctly.

• MFG—There is a manufacturing error that you must 
correct for the device to work correctly.

• Fatal—This fault caused the switch to fail.
• blank

Code Maps errors. For example, the code error 0x1ff0009 means 
block unauthorized map access of code that represents log 
description.

Task The system-assigned name of the task that generated the 
log entry.

Log Description A description of the log entry.

Locates specific entries in the log file. See “Locating 
specific log entries” on page 174.

Selects specific entries to display in the log file (eliminating, 
or filtering out, all other entries from the log). See “Filtering 
log entries” on page 176.

Deletes an entry from the log file. To delete multiple log 
entries, highlight all the log entries to delete before clicking 
this icon.

Closes the SysLog dialog box.

Table 55   SysLog dialog box items and buttons (continued)

Item or button Description
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Exporting a log file

To export a log file to the hard drive of your management station:

1 In the device view, click the diskette icon.

The Export sysLog dialog box opens (Figure 86).

Figure 86   Export sysLog dialog box

2 In the File name text box, type a name for your file, for example, syslog2.txt.

3 Click Save.

Locating specific log entries

You can locate specific log entries in Log Manager. For example, you can locate 
all entries containing a specified string without eliminating non-related table 
entries. 

To locate specific log entries:

1 In the device view, click Find.

The sysLog - Find dialog box opens (Figure 87).
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Figure 87   sysLog - Find dialog box

2 In the Find field, type the type the string you want to search for, for example, 
Fatal.

3 In the From field, check Selection (finds the first occurrence of your selection 
from your current position in the table) or Start (selects the first occurrence of 
your selection in the table).

4 Choose one or more of the following:

• Ignore Case, to ignore upper and lower case in the Find field

• Exact Match, to (match the string exactly as you typed it in the Find field

• By Row, to search by row or column. If By Row is deselected, the search 
is automatically by column.

5 Click Next. 

The fields containing matching strings are displayed in the SysLog dialog 
box. 

6 To proceed to the next field, in the syslog - Find dialog box, click Next. 

The next field is located and displayed in the SysLog dialog box.

7 To return to the previous field, in the syslog - Find dialog box, click Previous.

The previous field with a matching string is located and displayed in the 
SysLog dialog box.

8 To close the sysLog - Find dialog box, click Cancel.
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Filtering log entries

In Log Manager, you can display specific log entries by filtering out (removing) 
non-related log entries. 

To display specific log entries:

1 In the device view, click Filter.

The sysLog - Filter dialog box opens (Figure 88).

Figure 88   sysLog - Filter dialog box

2 In the Severity column, check the type of log entry or log entries to search for:

• All records

• INFO

• WARNING

• ERROR

• MFG

• FATAL

• blank

You can choose more than one type of log entry. 

Table 55 lists the severity level descriptions. If you choose blank, Log 
Manager filters for log entries that contain a blank field.

3 To narrow your search, type a character string that is part of the log 
description in the “contains string” field of your selected row(s).

4 Click Filter.
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5 The SysLog dialog box displays only the entries that satisfy the filtering 
criteria.

6 To restore all log entries in the SysLog dialog box:

a Select only “All records” in the severity column.

b Type “empty string”/”blank string” in the Contains string text box.

c Click Filter.

7 To close the sysLog - Filter dialog box, click Close.
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Appendix A
Additional reference sources

For more information about networking concepts, protocols, and topologies, you 
may want to consult the following sources:

• RFC 1058 (RIP version 1)

• RFC 1723 (RIP version 2)

• RFC 1213 (IP)

• RFC 1389 (RIP 2 Management Information Base)

• RFC 1493 (Bridge MIB)

• RFC 1573 (IANAIf Type)

• RFC 1643 (Ether-like MIB)

• RFC 1757 (RMON)

• RFC 1271 (RMON)

• RFC 1850 (OSPF MIB)

• RFC 1253 (OSPF)

• RFC 1583 (OSPF)

• RFC 2178 (OSPF)

• IEEE 802.1D (Standard for Spanning Tree Protocol)

• IEEE 802.3 (Ethernet)

• IEEE 802.1Q (VLAN Tagging)
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Appendix B
Troubleshooting and error messages

Resolving problems

Table 56 describes common Optivity Switch Manager problems and solutions.

Error messages

Table 57 describes Optivity Switch Manager messages and their meanings.

Table 56   Optivity Switch Manager problems and solutions

Problem Solution

Optivity Switch Manager does not 
display all network devices in the 
topology map.

• Use the ping command to verify that the 
network device is connected.

• Choose Edit > Preferences, and verify that the 
Automatically Relayout after discovery check box 
is selected in the Map section.

• Increase the maximum hop count in the 
Preferences dialog box.

Some devices have timed out. View the error log to determine if the timeout is due 
to the following, and take the recommended action:
• Invalid read-community string–add the correct 

community in the Edit Communities dialog box.
• Slow network–Increase the retry count in the 

SNMP section of the Edit Preferences dialog box.

• NMS socket overflow–Set the Max Outstanding 
Requests in the SNMP preferences section of the 
Edit Preferences dialog box.
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Table 57   Optivity Switch Manager error messages

Message Meaning

Discrepancies were found, see 
View > Audit

The submanager can still function, but it has found 
discrepancies between nodes. From the 
submanager menu bar, choose View > Audit to view 
the Audit dialog box.

Bad Assignment You attempted to edit a read-only item.
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Group tab, viewing L3-IGMP multicast group 
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viewing port status 115
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in the Route tab DVMRP table 153
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Internet Group Management Protocol. See IGMP

IpAddress field 144

IpAddress item
in the Default Ports table 77
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Isolated Device table 110

isolated routing port. See  IRP.

J
Joins field 143
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Layer 3 IGMP.  See L3-IGMP

Layout slider 52

LeafTimeOut field 148
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Mask item 87
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MaxAge field 74
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MemberPort field 138
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menu bar
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Multicast Manager 125
MultiLink Trunking Manager 102
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in the Interface tab DVMRP table 149
in the Route tab DVMRP table 153
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icon 106
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viewing 106

MLT Manager, features 25

Mode field 139

MRoute
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Route tab 154

MRouterExpiration item 133

MRouterPorts item 133

MRoutes 130

Multicast Group
about 156
Receivers tab 159
Source Subnets tab 157

Multicast groups, definition 130

Multicast Manager
active multicast routes 130
and IGMP Snoop 130
contents pane 127
DVMRP 130
features 26
highlighting multicast information in Optivity 

Switch Manager 160
L3-IGMP 130
location of active multicast groups 126
menu bar 125
Multicast Groups 130
navigation

contents pane 127
navigation pane 126
starting 123, 170
status bar 128
status bar icon field 129
status bar message field 129
viewing

forwarding node in Optivity Switch 
Manager 160
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multicast protocols 162
source subnet in Optivity Switch 

Manager 160
window 123

Multicast Manager icons
forwarding node 129
multicast group 129
source subnet 129

Multicast Route. See  MRoute.

multicast, definition 122

MultiLink Trunking Manager
configuring a MLT on two devices 113
configuring an MLT on one device 111
contents pane 103
creating a MLT 111
deleting an MLT 117
editing MLT information 117
features 100
highlighting devices and MLTs in Optivity 

Switch Manager 118
Isolated Device table 110
Isolated devices 109
menu bar 102
navigation tree 103
No trunk icon 108
No Trunk table 108
status bar 104
status bar message field 104
Trunk icon 106
Trunk table 107
viewing

isolated devices 118
MLTs in network map 118
no trunk devices 118
port link status 116
topology information 118

window 101

MultiLink Trunking Manager icons
isolated 104
no trunk 104
trunk 104

MultiLink Trunking Manager window
Status bar icon field 104

MultiLink Trunking. See MLT.
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Name field
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in the New VLAN dialog box 85

navigation
command buttons 30
information panel view 30
menu bar 30
navigation keys 30
navigation tree 30
scroll bars 30

navigation pane
Multicast Manager 126
VLAN Manager 60

NbrProbeInterval field 148

NbrTimeOut field 148

Neighbor tab 150
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port-based 83
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